inode man page on BSDi

Man page or keyword search:  
man Server   6284 pages
apropos Keyword Search (all sections)
Output format
BSDi logo
[printable version]

FS(5)			    BSD Programmer's Manual			 FS(5)

NAME
     fs, inode - format of filesystem volume

SYNOPSIS
     #include <sys/types.h>
     #include <ufs/ffs/fs.h>
     #include <ufs/ufs/dinode.h>

DESCRIPTION
     The files <ufs/ffs/fs.h> and <ufs/ufs/dinode.h> declare several struc-
     tures, defined variables and macros which are used to create and manage
     the underlying format of filesystem objects on random access devices
     (disks).

     The block size and number of blocks which comprise a filesystem are pa-
     rameters of the filesystem.  Sectors beginning at BBLOCK and continuing
     for BBSIZE are used for a disklabel and for some hardware primary and
     secondary bootstrapping programs.

     The actual filesystem begins at sector SBLOCK with the super-block that
     is of size SBSIZE. The following structure described the super-block and
     is from the file <ufs/ffs/fs.h>:

     #define FS_MAGIC 0x011954
     struct fs {
	     int32_t  fs_firstfield; /* historic file system linked list, */
	     int32_t  fs_unused_1;   /*	    used for incore super blocks */
	     ufs_daddr_t fs_sblkno;  /* addr of super-block in filesys */
	     ufs_daddr_t fs_cblkno;  /* offset of cyl-block in filesys */
	     ufs_daddr_t fs_iblkno;  /* offset of inode-blocks in filesys */
	     ufs_daddr_t fs_dblkno;  /* offset of first data after cg */
	     int32_t  fs_cgoffset;   /* cylinder group offset in cylinder */
	     int32_t  fs_cgmask;     /* used to calc mod fs_ntrak */
	     time_t   fs_time;	     /* last time written */
	     int32_t  fs_size;	     /* number of blocks in fs */
	     int32_t  fs_dsize;	     /* number of data blocks in fs */
	     int32_t  fs_ncg;	     /* number of cylinder groups */
	     int32_t  fs_bsize;	     /* size of basic blocks in fs */
	     int32_t  fs_fsize;	     /* size of frag blocks in fs */
	     int32_t  fs_frag;	     /* number of frags in a block in fs */
     /* these are configuration parameters */
	     int32_t  fs_minfree;    /* minimum percentage of free blocks */
	     int32_t  fs_rotdelay;   /* num of ms for optimal next block */
	     int32_t  fs_rps;	     /* disk revolutions per second */
     /* these fields can be computed from the others */
	     int32_t  fs_bmask;	     /* ``blkoff'' calc of blk offsets */
	     int32_t  fs_fmask;	     /* ``fragoff'' calc of frag offsets */
	     int32_t  fs_bshift;     /* ``lblkno'' calc of logical blkno */
	     int32_t  fs_fshift;     /* ``numfrags'' calc number of frags */
     /* these are configuration parameters */
	     int32_t  fs_maxcontig;  /* max number of contiguous blks */
	     int32_t  fs_maxbpg;     /* max number of blks per cyl group */
     /* these fields can be computed from the others */
	     int32_t  fs_fragshift;  /* block to frag shift */
	     int32_t  fs_fsbtodb;    /* fsbtodb and dbtofsb shift constant */
	     int32_t  fs_sbsize;     /* actual size of super block */
	     int32_t  fs_csmask;     /* csum block offset */
	     int32_t  fs_csshift;    /* csum block number */
	     int32_t  fs_nindir;     /* value of NINDIR */
	     int32_t  fs_inopb;	     /* value of INOPB */
	     int32_t  fs_nspf;	     /* value of NSPF */
     /* yet another configuration parameter */
	     int32_t  fs_optim;	     /* optimization preference, see below */
     /* these fields are derived from the hardware */
	     int32_t  fs_npsect;     /* # sectors/track including spares */
	     int32_t  fs_interleave; /* hardware sector interleave */
	     int32_t  fs_trackskew;  /* sector 0 skew, per track */
	     int32_t  fs_headswitch; /* head switch time, usec */
	     int32_t  fs_trkseek;    /* track-to-track seek, usec */
     /* sizes determined by number of cylinder groups and their sizes */
	     ufs_daddr_t fs_csaddr;  /* blk addr of cyl grp summary area */
	     int32_t  fs_cssize;     /* size of cyl grp summary area */
	     int32_t  fs_cgsize;     /* cylinder group size */
     /* these fields are derived from the hardware */
	     int32_t  fs_ntrak;	     /* tracks per cylinder */
	     int32_t  fs_nsect;	     /* sectors per track */
	     int32_t  fs_spc;		     /* sectors per cylinder */
     /* this comes from the disk driver partitioning */
	     int32_t  fs_ncyl;	     /* cylinders in file system */
     /* these fields can be computed from the others */
	     int32_t  fs_cpg;		     /* cylinders per group */
	     int32_t  fs_ipg;		     /* inodes per group */
	     int32_t  fs_fpg;		     /* blocks per group * fs_frag */
     /* this data must be re-computed after crashes */
	     struct  csum fs_cstotal;/* cylinder summary information */
     /* these fields are cleared at mount time */
	     int8_t   fs_fmod;	     /* super block modified flag */
	     int8_t   fs_clean;	     /* file system is clean flag */
	     int8_t   fs_ronly;	     /* mounted read-only flag */
	     int8_t   fs_flags;	     /* currently unused flag */
	     u_char   fs_fsmnt[MAXMNTLEN];   /* name mounted on */
     /* these fields retain the current block allocation info */
	     int32_t  fs_cgrotor;    /* last cg searched */
	     struct  csum *fs_csp[MAXCSBUFS];/* list of fs_cs info buffers */
	     int32_t  *fs_maxcluster;/* max cluster in each cyl group */
	     int32_t  fs_cpc;	     /* cyl per cycle in postbl */
	     int16_t  fs_opostbl[16][8];     /* old rotation block list head */
	     int32_t  fs_sparecon[50];	     /* reserved for future constants */
	     int32_t  fs_contigsumsize;	     /* size of cluster summary array */
	     int32_t  fs_maxsymlinklen;	     /* max length of an internal symlink */
	     int32_t  fs_inodefmt;   /* format of on-disk inodes */
	     u_int64_t fs_maxfilesize;	     /* maximum representable file size */
	     int64_t  fs_qbmask;     /* ~fs_bmask for use with 64-bit size */
	     int64_t  fs_qfmask;     /* ~fs_fmask for use with 64-bit size */
	     int32_t  fs_state;	     /* validate fs_clean field */
	     int32_t  fs_postblformat;	     /* format of positional layout tables */
	     int32_t  fs_nrpos;	     /* number of rotational positions */
	     int32_t  fs_postbloff;  /* (u_int16) rotation block list head */
	     int32_t  fs_rotbloff;   /* (u_int8) blocks for each rotation */
	     int32_t  fs_magic;	     /* magic number */
	     u_int8_t fs_space[1];   /* list of blocks for each rotation */
     /* actually longer */
     };

     Each disk drive contains some number of filesystems.  A filesystem con-
     sists of a number of cylinder groups.  Each cylinder group has inodes and
     data.

     A filesystem is described by its super-block, which in turn describes the
     cylinder groups.  The super-block is critical data and is replicated in
     each cylinder group to protect against catastrophic loss.	This is done
     at filesystem creation time and the critical super-block data does not
     change, so the copies need not be referenced further unless disaster
     strikes.

     Addresses stored in inodes are capable of addressing fragments of
     `blocks'. File system blocks of at most size MAXBSIZE can be optionally
     broken into 2, 4, or 8 pieces, each of which is addressable; these pieces
     may be DEV_BSIZE, or some multiple of a DEV_BSIZE unit.

     Large files consist of exclusively large data blocks.  To avoid undue
     wasted disk space, the last data block of a small file is allocated as
     only as many fragments of a large block as are necessary.	The filesystem
     format retains only a single pointer to such a fragment, which is a piece
     of a single large block that has been divided.  The size of such a frag-
     ment is determinable from information in the inode, using the blksize(fs,
     ip, lbn) macro.

     The filesystem records space availability at the fragment level; to de-
     termine block availability, aligned fragments are examined.

     The root inode is the root of the filesystem.  Inode 0 cannot be used for
     normal purposes and historically bad blocks were linked to inode 1, thus
     the root inode is 2.  Inode 1 is no longer used for this purpose; today
     inode 1 is used by the union filesystem (see mount_union(8))  to repre-
     sent a whiteout entry.

     The fs_minfree element gives the minimum acceptable percentage of
     filesystem blocks that may be free. If the freelist drops below this lev-
     el only the super-user may continue to allocate blocks.  The fs_minfree
     element may be set to 0 if no reserve of free blocks is deemed necessary.
     However, if the reserve is set below the level of fragmentation reported
     by fsck(8) (typically less than one percent) the filesystem may run out
     of full sized blocks.  If no full sized blocks are available, no files
     can be created that are larger than the largest fragment.	More practi-
     cally, severe performance degradations will be observed if the filesystem
     is run at greater than 95% full; for clustering to be most effective for
     large files, the filesystem should be run at a maximum of 90% full.
     Thus, the default value of fs_minfree is 10%.

     Empirically the best trade-off between block fragmentation and overall
     disk utilization at a loading of 90% comes with a fragmentation of 8,
     thus the default fragment size is an eighth of the block size.

     The element fs_optim specifies whether the filesystem should try to mini-
     mize the time spent allocating blocks, or if it should attempt to mini-
     mize the space fragmentation on the disk.	If the value of fs_minfree
     (see above) is less than 10%, then the filesystem defaults to optimizing
     for space to avoid running out of full sized blocks.  If the value of
     minfree is greater than or equal to 10%, fragmentation is unlikely to be
     problematical and the filesystem defaults to optimizing for time.	During
     operation, the filesystem monitors the level of fragmentation.  If it
     rises to within half of minfree, the optimization is switched to space.
     If it drops to less than a quarter of minfree, the optimization is
     switched to time.

     Cylinder group related limits: Each cylinder keeps track of the avail-
     ability of blocks at different rotational positions, so that sequential
     blocks can be laid out with minimum rotational latency. With the default
     of 8 distinguished rotational positions, the resolution of the summary
     information is 4ms for a typical 7200 rpm drive.  Many modern disks hide
     their real geometry from the filesystem.  No rotational layout tables are
     built for such disks; instead the filesystem simply tries to lay out
     files as contiguously as possible.

     The element fs_rotdelay gives the minimum number of milliseconds to ini-
     tiate another disk transfer on the same cylinder.	It is used in deter-
     mining the rotationally optimal layout for disk blocks within a file; the
     default value for fs_rotdelay is 2ms.

     Each filesystem has a statically allocated number of inodes.  An inode is
     allocated for each NBPI bytes of disk space.  The inode allocation strat-
     egy is extremely conservative since a filesystem cannot create any new
     files if it runs out of inodes.

     MINBSIZE is the smallest allowable block size.  With a MINBSIZE of 4096
     it is possible to create files of size 2^32 with only two levels of indi-
     rection.  MINBSIZE must be big enough to hold a cylinder group block,
     thus changes to (struct cg) must keep its size within MINBSIZE. Note that
     super-blocks are never more than size SBSIZE.

     The path name on which the filesystem is mounted is maintained in
     fs_fsmnt. MAXMNTLEN defines the amount of space allocated in the super-
     block for this name.  The limit on the amount of summary information per
     filesystem is defined by MAXCSBUFS. For a 4096 byte block size, it is
     currently parameterized for a maximum of two million cylinders.

     Per cylinder group information is summarized in blocks allocated from the
     first cylinder group's data blocks.  These blocks are read in from
     fs_csaddr (size fs_cssize) in addition to the super-block.

     N.B.: sizeof(struct csum)	must be a power of two in order for the
     fs_cs() macro to work.

     The Super-block for a filesystem: The size of the rotational layout ta-
     bles is limited by the fact that the super-block is of size SBSIZE. The
     size of these tables is inversely proportional to the block size of the
     filesystem. The size of the tables is increased when sector sizes are not
     powers of two, as this increases the number of cylinders included before
     the rotational pattern repeats (fs_cpc). The size of the rotational lay-
     out tables is derived from the number of bytes remaining in (struct fs).

     The number of blocks of data per cylinder group is limited because cylin-
     der groups are at most one block.	The inode and free block tables must
     fit into a single block after deducting space for the cylinder group
     structure (struct cg).

     The Inode: The inode is the focus of all file activity in the filesystem.
     There is a unique inode allocated for each active file, each current di-
     rectory, each mounted-on file, text file, and the root.  An inode is
     `named' by its device/i-number pair.  For further information, see the
     include file <ufs/ufs/dinode.h>.

HISTORY
     A super-block structure named filsys appeared in Version 6 AT&T UNIX.
     The filesystem described in this manual appeared in 4.2BSD.

4.2 Berkeley Distribution      December 25, 1996			     4
[top]

List of man pages available for BSDi

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net