INIT(8) BSD System Manager's Manual INIT(8)NAMEinit — process control initialization
The init program is the last stage of the boot process. It normally runs
the automatic reboot sequence as described in reboot(8), and if this suc‐
ceeds, begins multi-user operation. If the reboot scripts fail, init
commences single user operation by giving the super-user a shell on the
console. The init program may be passed parameters from the boot program
to prevent the system from going multi-user and to instead execute a sin‐
gle user shell without starting the normal daemons. The system is then
quiescent for maintenance work and may later be made to go to multi-user
by exiting the single-user shell (with ^D). This causes init to run the
/etc/rc start up command file in fastboot mode (skipping disk checks).
If the console entry in the ttys(5) file is marked ``insecure'', then
init will require that the superuser password be entered before the sys‐
tem will start a single-user shell. The password check is skipped if the
console is marked as ``secure''.
The kernel runs with four different levels of security. Any superuser
process can raise the security level, but only init can lower it. Secu‐
rity levels are defined as follows:
-1 Permanently insecure mode - always run system in level 0 mode.
0 Insecure mode - immutable and append-only flags may be turned off.
All devices may be read or written subject to their permissions.
1 Secure mode - immutable and append-only flags may not be changed;
disks for mounted filesystems, /dev/mem, and /dev/kmem are read-
only. The settimeofday(2) system call can only advance the time.
2 Highly secure mode - same as secure mode, plus disks are always
read-only whether mounted or not. This level precludes tampering
with filesystems by unmounting them, but also inhibits running
newfs(8) while the system is multi-user.
Normally, the system runs in level 0 mode while single user and in level
1 mode while multiuser. If the level 2 mode is desired while running
multiuser, it can be set in the startup script /etc/rc using sysctl(8).
If it is desired to run the system in level 0 mode while multiuser, the
administrator must build a kernel with the variable securelevel defined
in the file /sys/compile/MACHINE/param.c and initialize it to -1.
In multi-user operation, init maintains processes for the terminal ports
found in the file ttys(5). Init reads this file, and executes the com‐
mand found in the second field. This command is usually getty(8); getty
opens and initializes the tty line and executes the login program. The
login program, when a valid user logs in, executes a shell for that user.
When this shell dies, either because the user logged out or an abnormal
termination occurred (a signal), the init program wakes up, deletes the
user from the utmp(5) file of current users and records the logout in the
wtmp file. The cycle is then restarted by init executing a new getty for
Line status (on, off, secure, getty, or window information) may be
changed in the ttys file without a reboot by sending the signal SIGHUP to
init with the command “kill -s HUP 1”. On receipt of this signal, init
re-reads the ttys file. When a line is turned off in ttys, init will
send a SIGHUP signal to the controlling process for the session associ‐
ated with the line. For any lines that were previously turned off in the
ttys file and are now on, init executes a new getty to enable a new
login. If the getty or window field for a line is changed, the change
takes effect at the end of the current login session (e.g., the next time
init starts a process on the line). If a line is commented out or
deleted from ttys, init will not do anything at all to that line. How‐
ever, it will complain that the relationship between lines in the ttys
file and records in the utmp file is out of sync, so this practice is not
Init will terminate multi-user operations and resume single-user mode if
sent a terminate (TERM) signal, for example, “kill -s TERM 1”. If there
are processes outstanding that are deadlocked (because of hardware or
software failure), init will not wait for them all to die (which might
take forever), but will time out after 30 seconds and print a warning
Init will cease creating new getty's and allow the system to slowly die
away, if it is sent a terminal stop (TSTP) signal, i.e. “kill -s TSTP
1”. A later hangup will resume full multi-user operations, or a termi‐
nate will start a single user shell. This hook is used by reboot(8) and
The role of init is so critical that if it dies, the system will reboot
itself automatically. If, at bootstrap time, the init process cannot be
located, the system will panic with the message ``panic: "init died (sig‐
nal %d, exit %d)''.
getty repeating too quickly on port %s, sleeping A process being started
to service a line is exiting quickly each time it is started. This is
often caused by a ringing or noisy terminal line. Init will sleep for 10
seconds, then continue trying to start the process.
some processes would not die; ps axl advised. A process is hung and
could not be killed when the system was shutting down. This condition is
usually caused by a process that is stuck in a device driver because of a
persistent device error condition.
/dev/console System console device.
/dev/tty* Terminal ports found in ttys.
/var/run/utmp Record of Current users on the system.
/var/log/wtmp Record of all logins and logouts.
/etc/ttys The terminal initialization information file.
/etc/rc System startup commands.
SEE ALSOlogin(1), kill(1), sh(1), ttys(5), crash(8), getty(8), rc(8), reboot(8),
A init command appeared in Version 6 AT&T UNIX.
Systems without sysctl behave as though they have security level -1.
4th Berkeley Distribution May 26, 1995 4th Berkeley Distribution