igmp man page on BSDOS

Man page or keyword search:  
man Server   6284 pages
apropos Keyword Search (all sections)
Output format
BSDOS logo
[printable version]

IGMP(4)			    BSD Programmer's Manual		       IGMP(4)

NAME
     igmp - Internet Control Message Protocol

SYNOPSIS
     #include <sys/socket.h>
     #include <netinet/in.h>

     int
     socket(AF_INET, SOCK_RAW, proto);

DESCRIPTION
     IGMP is the multicast group management protocol used to support multicas-
     ting for IP and the Internet protocol family.  It may be accessed through
     a ``raw socket'' for IP multicast monitoring and diagnostic functions.
     The proto parameter to the socket call to create an IGMP socket is ob-
     tained from getprotobyname(3).  IGMP sockets are connectionless, and are
     normally used with the sendto and recvfrom calls, though the connect(2)
     call may also be used to fix the destination for future packets (in which
     case the read(2) or recv(2) and write(2) or send(2) system calls may be
     used).

     Outgoing packets automatically have an IP header prepended to them (based
     on the destination address) unless IP_HDRINCL option has been specified.
     Incoming packets are received with the IP header and options intact.

SYSCTL VARIABLES
     Some IGMP options can be read or written via the sysctl(3) facility.
     Variables specific to IGMP are:

   CTL_NET, PF_INET, IPPROTO_IGMP
     These variables are used to get or set various global ICMP options.

     Fourth level name	 Type	       Changeable
     IGMPCTL_STATS	 struct	       no

     IGMPCTL_STATS
	     Returns the struct igmpstat containing statistics on the process-
	     ing of IGMP packets.

DIAGNOSTICS
     A socket operation may fail with one of the following errors returned:

     [EISCONN]	      when trying to establish a connection on a socket which
		      already has one, or when trying to send a datagram with
		      the destination address specified and the socket is al-
		      ready connected;

     [ENOTCONN]	      when trying to send a datagram, but no destination ad-
		      dress is specified, and the socket hasn't been connect-
		      ed;

     [ENOBUFS]	      when the system runs out of memory for an internal data
		      structure;

     [EADDRNOTAVAIL]  when an attempt is made to create a socket with a net-
		      work address for which no network interface exists.

SEE ALSO
     send(2),  recv(2),	 sysctl(3),  intro(4),	inet(4),  ip(4)

4.3 Berkeley Distribution	 June 5, 1993				     1
[top]
                             _         _         _ 
                            | |       | |       | |     
                            | |       | |       | |     
                         __ | | __ __ | | __ __ | | __  
                         \ \| |/ / \ \| |/ / \ \| |/ /  
                          \ \ / /   \ \ / /   \ \ / /   
                           \   /     \   /     \   /    
                            \_/       \_/       \_/ 
More information is available in HTML format for server BSDOS

List of man pages available for BSDOS

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net