ieee80211_crypto man page on NetBSD

Man page or keyword search:  
man Server   9087 pages
apropos Keyword Search (all sections)
Output format
NetBSD logo
[printable version]

IEEE80211_CRYPTO(9)	 BSD Kernel Developer's Manual	   IEEE80211_CRYPTO(9)

NAME
     ieee80211_crypto_attach, ieee80211_crypto_detach, ieee80211_crypto_encap
     — 802.11 WEP encryption functions

SYNOPSIS
     void
     ieee80211_crypto_attach(struct ieee80211com *ic);

     void
     ieee80211_crypto_detach(struct ieee80211com *ic);

     struct ieee80211_key *
     ieee80211_crypto_encap(struct ieee80211com *ic,
	 struct ieee80211_node *ni, struct mbuf *m0);

DESCRIPTION
     These functions provide encryption support for 802.11 device drivers.

     The ieee80211_crypto_attach() function initializes crypto support for the
     interface ic.  The default is null crypto.

     The ieee80211_crypto_detach() function frees data structures associated
     with crypto support for the interface ic.

     The two above functions are automatically called by the interface attach
     and detach routines, respectively.

     The ieee80211_crypto_encap() function encapsulates the packet supplied in
     mbuf m0, with the crypto headers given the for node ni.  Software encryp‐
     tion is possibly performed.  In case of no specified key for ni or multi‐
     cast traffic, the default key for the interface ic is used for encapsula‐
     tion.  The key is returned in the case of successful encapsulation, oth‐
     erwise NULL is returned.

SEE ALSO
     ieee80211(9)

HISTORY
     The ieee80211 series of functions first appeared in NetBSD 1.5, and were
     later ported to FreeBSD 4.6.

AUTHORS
     This man page was written by Bruce M. Simpson ⟨bms@FreeBSD.org⟩ and
     Darron Broad ⟨darron@kewl.org⟩.

BSD			      September 12, 2006			   BSD
[top]
                             _         _         _ 
                            | |       | |       | |     
                            | |       | |       | |     
                         __ | | __ __ | | __ __ | | __  
                         \ \| |/ / \ \| |/ / \ \| |/ /  
                          \ \ / /   \ \ / /   \ \ / /   
                           \   /     \   /     \   /    
                            \_/       \_/       \_/ 
More information is available in HTML format for server NetBSD

List of man pages available for NetBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net