icmp man page on BSDi

Man page or keyword search:  
man Server   6284 pages
apropos Keyword Search (all sections)
Output format
BSDi logo
[printable version]

ICMP(4)			    BSD Programmer's Manual		       ICMP(4)

NAME
     icmp - Internet Control Message Protocol

SYNOPSIS
     #include <sys/socket.h>
     #include <netinet/in.h>

     int
     socket(AF_INET, SOCK_RAW, proto);

DESCRIPTION
     ICMP is the error and control message protocol used by IP and the Inter-
     net protocol family.  It may be accessed through a ``raw socket'' for
     network monitoring and diagnostic functions.  The proto parameter to the
     socket call to create an ICMP socket is obtained from getprotobyname(3).
     ICMP sockets are connectionless, and are normally used with the sendto
     and recvfrom calls, though the connect(2) call may also be used to fix
     the destination for future packets (in which case the read(2) or recv(2)
     and write(2) or send(2) system calls may be used).

     Outgoing packets automatically have an IP header prepended to them (based
     on the destination address) unless IP_HDRINCL option has been specified.
     Incoming packets are received with the IP header and options intact.

SYSCTL VARIABLES
     Some ICMP options can be read or written via the sysctl(3) facility.
     Variables specific to ICMP are:

   CTL_NET, PF_INET, IPPROTO_ICMP
     These variables are used to get or set various global ICMP options.

     Fourth level name		Type	      Changeable
     ICMPCTL_MASKREPL		integer	      yes
     ICMPCTL_PRINTFS		integer	      yes
     ICMPCTL_REDIRACCEPT	integer	      yes
     ICMPCTL_REDIRTIMEOUT	integer	      yes
     ICMPCTL_STATS		struct	      no

     ICMPCTL_MASKREPL
	     Returns 1 if ICMP network mask requests are to be answered.

     ICMPCTL_PRINTFS
	     Returns 1 if certain ICMP debugging statements are enabled if the
	     kernel is compiled with this facility enabled.

     ICMPCTL_REDIRACCEPT
	     Returns 1 when ICMP redirects are allowed to update the routing
	     table.  ICMP redirects are normally enabled on hosts and disabled
	     on routers that use a dynamic routing protocol.

     ICMPCTL_REDIRTIMEOUT
	     Returns the length of time in seconds before routing table en-
	     tries created by ICMP redirects are removed.

     ICMPCTL_STATS
	     Returns the struct icmpstat structure containing statistics on
	     the processing of ICMP packets.

DIAGNOSTICS
     A socket operation may fail with one of the following errors returned:

     [EISCONN]	      when trying to establish a connection on a socket which
		      already has one, or when trying to send a datagram with
		      the destination address specified and the socket is al-
		      ready connected;

     [ENOTCONN]	      when trying to send a datagram, but no destination ad-
		      dress is specified, and the socket hasn't been connect-
		      ed;

     [ENOBUFS]	      when the system runs out of memory for an internal data
		      structure;

     [EADDRNOTAVAIL]  when an attempt is made to create a socket with a net-
		      work address for which no network interface exists.

SEE ALSO
     send(2),  recv(2),	 sysctl(3),  intro(4),	inet(4),  ip(4)

HISTORY
     The icmp protocol appeared in 4.3BSD.

4.3 Berkeley Distribution	 June 5, 1993				     2
[top]

List of man pages available for BSDi

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net