hz man page on NetBSD

Man page or keyword search:  
man Server   9087 pages
apropos Keyword Search (all sections)
Output format
NetBSD logo
[printable version]

HZ(9)			 BSD Kernel Developer's Manual			 HZ(9)

NAME
     hz, tick, tickadj, stathz, profhz — system time model

SYNOPSIS
     #include <sys/kernel.h>

     extern int hz;
     extern int tick;
     extern int tickadj;
     extern int stathz;
     extern int profhz;

DESCRIPTION
     The essential clock handling routines in NetBSD are written to operate
     with two timers that run independently of each other.  The main clock,
     running hz times per second, is used to keep track of real time.

     In another words, hz specifies the number of times the hardclock(9) timer
     ticks per second.	Normally hardclock(9) increments time by tick each
     time it is called.	 If the system clock has drifted, adjtime(2) may be
     used to skew this increment based on the rate of tickadj.

     The second timer is used to gather timing statistics.  It also handles
     kernel and user profiling.	 If the second timer is programmable, it is
     randomized to avoid aliasing between the two clocks.  The mean frequency
     of the second timer is stathz.  If a separate clock is not available,
     stathz is set to hz.

     If profiling is enabled, the clock normally used to drive stathz may be
     run at a higher rate profhz, which is required to be a multiple of
     stathz.  This will give higher resolution profiling information.

     These system variables are also available as struct clockinfo from
     sysctl(3) and kern.clockrate from sysctl(8).  The hz is hardware-depen‐
     dent; it can be overridden (if the machine dependent code supports this)
     by defining HZ in the kernel configuration file (see options(4)).	Only
     override the default value if you really know what you are doing.

SEE ALSO
     adjtime(2), callout(9), hardclock(9), microtime(9), time_second(9)

BSD				March 25, 2010				   BSD
[top]
                             _         _         _ 
                            | |       | |       | |     
                            | |       | |       | |     
                         __ | | __ __ | | __ __ | | __  
                         \ \| |/ / \ \| |/ / \ \| |/ /  
                          \ \ / /   \ \ / /   \ \ / /   
                           \   /     \   /     \   /    
                            \_/       \_/       \_/ 
More information is available in HTML format for server NetBSD

List of man pages available for NetBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net