gpt man page on NetBSD

Man page or keyword search:  
man Server   9087 pages
apropos Keyword Search (all sections)
Output format
NetBSD logo
[printable version]

GPT(8)			  BSD System Manager's Manual			GPT(8)

NAME
     gpt — GUID partition table maintenance utility

SYNOPSIS
     gpt [general_options] command [command_options] device ...

DESCRIPTION
     The gpt utility provides the necessary functionality to manipulate GUID
     partition tables (GPTs), but see BUGS below for how and where functional‐
     ity is missing.  The basic usage model of the gpt tool follows that of
     the cvs(1) tool.  The general options are described in the following
     paragraph.	 The remaining paragraphs describe the individual commands
     with their options.  Here we conclude by mentioning that a device is
     either a special file corresponding to a disk-like device or a regular
     file.  The command is applied to each device listed on the command line.

   General Options
     The general options allow the user to change default settings or other‐
     wise change the behaviour that is applicable to all commands.  Not all
     commands use all default settings, so some general options may not have
     an effect on all commands.

     The -p count option allows the user to change the number of partitions
     the GPT can accommodate.  This is used whenever a new GPT is created.  By
     default, the gpt utility will create space for 128 partitions (or 32 sec‐
     tors of 512 bytes).

     The -r option causes the gpt utility to open the device for reading only.
     Currently this option is primarily useful for the show command, but the
     intent is to use it to implement dry-run behaviour.

     The -v option controls the verbosity level.  The level increases with
     every occurrence of this option.  There is no formalized definition of
     the different levels yet.

   Commands
     gpt add [-b number] [-i index] [-s count] [-t type] device ...
	     The add command allows the user to add a new partition to an
	     existing table.  By default, it will create a UFS partition cov‐
	     ering the first available block of an unused disk space.  The
	     command-specific options can be used to control this behaviour.

	     The -b number option allows the user to specify the starting
	     (beginning) sector number of the partition.  The minimum sector
	     number is 1, but has to fall inside an unused region of disk
	     space that is covered by the GPT.

	     The -i index option allows the user to specify which (free) entry
	     in the GPT table is to be used for the new partition.  By
	     default, the first free entry is selected.

	     The -s count option allows the user to specify the size of the
	     partition in sectors.  The minimum size is 1.

	     The -t type option allows the user to specify the partition type.
	     The type is given as an UUID, but gpt accepts efi, swap, ufs,
	     hfs, linux, raid, lfs, ccd, cgd, bios, ffs, and windows as
	     aliases for the most commonly used partition types.

     gpt biosboot [-c bootcode] [-i index] device ...
	     The biosboot command allows the user to configure the partition
	     that contains the primary bootstrap program, used during boot(8).

	     The -c option allows the user to specify the filename that gpt
	     should read the bootcode from.  The default is to read from
	     /usr/mdec/gptmbr.bin.

	     The -i option selects the partition that should contain the pri‐
	     mary bootstrap code, as installed via installboot(8).

     gpt create [-fp] device ...
	     The create command allows the user to create a new (empty) GPT.
	     By default, one cannot create a GPT when the device contains a
	     MBR, however this can be overridden with the -f option.  If the
	     -f option is specified, an existing MBR is destroyed and any par‐
	     titions described by the MBR are lost.

	     The -p option tells gpt to create only the primary table and not
	     the backup table.	This option is only useful for debugging and
	     should not be used otherwise.

     gpt destroy [-r] device ...
	     The destroy command allows the user to destroy an existing, pos‐
	     sibly not empty GPT.

	     The -r option instructs gpt to destroy the table in a way that it
	     can be recovered.

     gpt label [-a] ⟨-f file | -l label⟩ device ...

     gpt label [-b number] [-i index] [-s count] [-t type] ⟨-f file | -l
	     label⟩ device ...
	     The label command allows the user to label any partitions that
	     match the selection.  At least one of the following selection
	     options must be specified.

	     The -a option specifies that all partitions should be labeled.
	     It is mutually exclusive with all other selection options.

	     The -b number option selects the partition that starts at the
	     given block number.

	     The -i index option selects the partition with the given parti‐
	     tion number.

	     The -s count option selects all partitions that have the given
	     size.  This can cause multiple partitions to be removed.

	     The -t type option selects all partitions that have the given
	     type.  The type is given as an UUID or by the aliases that the
	     add command accepts.  This can cause multiple partitions to be
	     removed.

	     The -f file or -l label options specify the new label to be
	     assigned to the selected partitions.  The -f file option is used
	     to read the label from the specified file.	 Only the first line
	     is read from the file and the trailing newline character is
	     stripped.	If the file name is the dash or minus sign (-), the
	     label is read from the standard input.  The -l label option is
	     used to specify the label in the command line.  The label is
	     assumed to be encoded in UTF-8.

     gpt migrate [-fs] device ...
	     The migrate command allows the user to migrate an MBR-based disk
	     partitioning into a GPT-based partitioning.  By default, the MBR
	     is not migrated when it contains partitions of an unknown type.
	     This can be overridden with the -f option.	 Specifying the -f
	     option will cause unknown partitions to be ignored and any data
	     in it to be lost.

	     The -s option prevents migrating BSD disk labels into GPT parti‐
	     tions by creating the GPT equivalent of a slice.

     gpt recover device ...
	     The recover command tries to restore the GPT partition label from
	     the backup near the end of the disk.  It is very useful in case
	     the primary label was deleted.

     gpt remove [-a] device ...

     gpt remove [-b number] [-i index] [-s count] [-t type] device ...
	     The remove command allows the user to remove any and all parti‐
	     tions that match the selection.  It uses the same selection
	     options as the label command.  See above for a description of
	     these options.  Partitions are removed by clearing the partition
	     type.  No other information is changed.

     gpt show [-lu] device ...
	     The show command displays the current partitioning on the listed
	     devices and gives an overall view of the disk contents.  With the
	     -l option the GPT partition label will be displayed instead of
	     the GPT partition type.  The option has no effect on non-GPT par‐
	     titions.  With the -u option the GPT partition type is displayed
	     as an UUID instead of in a user friendly form.  The -l option
	     takes precedence over the -u option.

EXAMPLES
     nas# gpt show wd3
	    start	 size  index  contents
		0	    1	      PMBR
		1  3907029167
     nas# gpt create wd3
     nas# gpt show wd3
	    start	 size  index  contents
		0	    1	      PMBR
		1	    1	      Pri GPT header
		2	   32	      Pri GPT table
	       34  3907029101
       3907029135	   32	      Sec GPT table
       3907029167	    1	      Sec GPT header
     nas# gpt add -s 10486224 -t swap -i 1 wd3
     Partition added, use:
	     dkctl rwd3d addwedge dk<N> 34 10486224 <type>
     to create a wedge for it
     nas# gpt label -i 1 -l swap_1 wd3
     parition 1 on rwd3d labeled swap_1
     nas# gpt show wd3
	    start	 size  index  contents
		0	    1	      PMBR
		1	    1	      Pri GPT header
		2	   32	      Pri GPT table
	       34    10486224	   1  GPT part - NetBSD swap
	 10486258  3896542877
       3907029135	   32	      Sec GPT table
       3907029167	    1	      Sec GPT header
     nas#

SEE ALSO
     boot(8), fdisk(8), installboot(8), mount(8), newfs(8), swapon(8)

HISTORY
     The gpt utility appeared in FreeBSD 5.0 for ia64.

BUGS
     The development of the gpt utility is still work in progress.  Many nec‐
     essary features are missing or partially implemented.  In practice this
     means that the manual page, supposed to describe these features, is far‐
     ther removed from being complete or useful.  As such, missing functional‐
     ity is not even documented as missing.  However, it is believed that the
     currently present functionality is reliable and stable enough that this
     tool can be used without bullet-proof footware if one thinks one does not
     make mistakes.

     It is expected that the basic usage model does not change, but it is pos‐
     sible that future versions will not be compatible in the strictest sense
     of the word.  For example, the -p count option may be changed to a com‐
     mand option rather than a generic option.	There are only two commands
     that use it so there is a chance that the natural tendency for people is
     to use it as a command option.  Also, options primarily intended for
     diagnostic or debug purposes may be removed in future versions.

     Another possibility is that the current usage model is accompanied by
     other interfaces to make the tool usable as a back-end.  This all depends
     on demand and thus feedback.

BSD				 March 9, 2012				   BSD
[top]
                             _         _         _ 
                            | |       | |       | |     
                            | |       | |       | |     
                         __ | | __ __ | | __ __ | | __  
                         \ \| |/ / \ \| |/ / \ \| |/ /  
                          \ \ / /   \ \ / /   \ \ / /   
                           \   /     \   /     \   /    
                            \_/       \_/       \_/ 
More information is available in HTML format for server NetBSD

List of man pages available for NetBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net