gettytab man page on 4.4BSD

Man page or keyword search:  
man Server   1065 pages
apropos Keyword Search (all sections)
Output format
4.4BSD logo
[printable version]

GETTYTAB(5)		    BSD File Formats Manual		   GETTYTAB(5)

NAME
     gettytab — terminal configuration data base

SYNOPSIS
     gettytab

DESCRIPTION
     The gettytab file is a simplified version of the termcap(5) data base
     used to describe terminal lines.  The initial terminal login process
     getty(8) accesses the gettytab file each time it starts, allowing simpler
     reconfiguration of terminal characteristics.  Each entry in the data base
     is used to describe one class of terminals.

     There is a default terminal class, default, that is used to set global
     defaults for all other classes.  (That is, the default entry is read,
     then the entry for the class required is used to override particular set‐
     tings.)

CAPABILITIES
     Refer to termcap(5) for a description of the file layout.	The default
     column below lists defaults obtained if there is no entry in the table
     obtained, nor one in the special default table.

     Name      Type		 Default    Description
     ap	       bool		 false	    terminal uses any parity
     bd	       num		 0	    backspace delay
     bk	       str		 0377	    alternate end of line character
					    (input break)
     cb	       bool		 false	    use crt backspace mode
     cd	       num		 0	    carriage-return delay
     ce	       bool		 false	    use crt erase algorithm
     ck	       bool		 false	    use crt kill algorithm
     cl	       str		 NULL	    Ta screen clear sequence
     co	       bool		 false	    console - add ‘\n’ after login
					    prompt
     ds	       str		 ‘^Y’	    delayed suspend character
     dx	       bool		 false	    set DECCTLQ
     ec	       bool		 false	    leave echo OFF
     ep	       bool		 false	    terminal uses even parity
     er	       str		 ‘^?’	    erase character
     et	       str		 ‘^D’	    end of text (EOF) character
     ev	       str		 NULL	    Ta initial environment
     f0	       num		 unused	    tty mode flags to write messages
     f1	       num		 unused	    tty mode flags to read login name
     f2	       num		 unused	    tty mode flags to leave terminal
					    as
     fd	       num		 0	    form-feed (vertical motion) delay
     fl	       str		 ‘^O’	    output flush character
     hc	       bool		 false	    do NOT hangup line on last close
     he	       str		 NULL	    Ta hostname editing string
     hn	       str		 hostname   hostname
     ht	       bool		 false	    terminal has real tabs
     ig	       bool		 false	    ignore garbage characters in login
					    name
     im	       str		 NULL	    initial (banner) message
     in	       str		 ‘^C’	    interrupt character
     is	       num		 unused	    input speed
     kl	       str		 ‘^U’	    kill character
     lc	       bool		 false	    terminal has lower case
     lm	       str		 login:	    login prompt
     ln	       str		 ‘^V’	    ``literal next'' character
     lo	       str		 /usr/bin/loginprogram to exec when name
					    obtained
     nd	       num		 0	    newline (line-feed) delay
     nl	       bool		 false	    terminal has (or might have) a
					    newline character
     np	       bool		 false	    terminal uses no parity (i.e.
					    8-bit characters)
     nx	       str		 default    next table (for auto speed
					    selection)
     op	       bool		 false	    terminal uses odd parity
     os	       num		 unused	    output speed
     pc	       str		 ‘\0’	    pad character
     pe	       bool		 false	    use printer (hard copy) erase
					    algorithm
     pf	       num		 0	    delay between first prompt and
					    following flush (seconds)
     ps	       bool		 false	    line connected to a MICOM port
					    selector
     qu	       str		 ‘^\’	    quit character
     rp	       str		 ‘^R’	    line retype character
     rw	       bool		 false	    do NOT use raw for input, use
					    cbreak
     sp	       num		 unused	    line speed (input and output)
     su	       str		 ‘^Z’	    suspend character
     tc	       str		 none	    table continuation
     to	       num		 0	    timeout (seconds)
     tt	       str		 NULL	    terminal type (for environment)
     ub	       bool		 false	    do unbuffered output (of prompts
					    etc)
     uc	       bool		 false	    terminal is known upper case only
     we	       str		 ‘^W’	    word erase character
     xc	       bool		 false	    do NOT echo control chars as ‘^X’
     xf	       str		 ‘^S’	    XOFF (stop output) character
     xn	       str		 ‘^Q’	    XON (start output) character

     If no line speed is specified, speed will not be altered from that which
     prevails when getty is entered.  Specifying an input or output speed will
     override line speed for stated direction only.

     Terminal modes to be used for the output of the message, for input of the
     login name, and to leave the terminal set as upon completion, are derived
     from the boolean flags specified.	If the derivation should prove inade‐
     quate, any (or all) of these three may be overridden with one of the f0,
     f1, or f2 numeric specifications, which can be used to specify (usually
     in octal, with a leading '0') the exact values of the flags.  Local (new
     tty) flags are set in the top 16 bits of this (32 bit) value.

     Should getty receive a null character (presumed to indicate a line break)
     it will restart using the table indicated by the nx entry. If there is
     none, it will re-use its original table.

     Delays are specified in milliseconds, the nearest possible delay avail‐
     able in the tty driver will be used.  Should greater certainty be
     desired, delays with values 0, 1, 2, and 3 are interpreted as choosing
     that particular delay algorithm from the driver.

     The cl screen clear string may be preceded by a (decimal) number of mil‐
     liseconds of delay required (a la termcap).  This delay is simulated by
     repeated use of the pad character pc.

     The initial message, and login message, im and lm may include the charac‐
     ter sequence %h or %t to obtain the hostname or tty name respectively.
     (%% obtains a single '%' character.)  The hostname is normally obtained
     from the system, but may be set by the hn table entry.  In either case it
     may be edited with he.  The he string is a sequence of characters, each
     character that is neither '@' nor '#' is copied into the final hostname.
     A '@' in the he string, causes one character from the real hostname to be
     copied to the final hostname.  A '#' in the he string, causes the next
     character of the real hostname to be skipped.  Surplus '@' and '#' char‐
     acters are ignored.

     When getty execs the login process, given in the lo string (usually
     “/usr/bin/login”), it will have set the environment to include the termi‐
     nal type, as indicated by the tt string (if it exists).  The ev string,
     can be used to enter additional data into the environment.	 It is a list
     of comma separated strings, each of which will presumably be of the form
     name=value.

     If a non-zero timeout is specified, with to, then getty will exit within
     the indicated number of seconds, either having received a login name and
     passed control to login, or having received an alarm signal, and exited.
     This may be useful to hangup dial in lines.

     Output from getty is even parity unless op is specified.  The op string
     may be specified with ap to allow any parity on input, but generate odd
     parity output.  Note: this only applies while getty is being run, termi‐
     nal driver limitations prevent a more complete implementation.  Getty
     does not check parity of input characters in RAW mode.

SEE ALSO
     login(1), termcap(5), getty(8).

BUGS
     The special characters (erase, kill, etc.) are reset to system defaults
     by login(1).  In all cases, '#' or '^H' typed in a login name will be
     treated as an erase character, and '@' will be treated as a kill charac‐
     ter.

     The delay stuff is a real crock.  Apart form its general lack of flexi‐
     bility, some of the delay algorithms are not implemented.	The terminal
     driver should support sane delay settings.

     The he capability is stupid.

     The termcap format is horrid, something more rational should have been
     chosen.

HISTORY
     The gettytab file format appeared in 4.2BSD.

4.2 Berkeley Distribution	 June 1, 1994	     4.2 Berkeley Distribution
[top]

List of man pages available for 4.4BSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net