genassym.cf man page on MirBSD

Man page or keyword search:  
man Server   6113 pages
apropos Keyword Search (all sections)
Output format
MirBSD logo
[printable version]

GENASSYM.CF(5)		     BSD Reference Manual		GENASSYM.CF(5)

NAME
     genassym.cf - assym.h definition file

DESCRIPTION
     The genassym.cf file is used by genassym.sh(8) to make constant C expres-
     sions known to assembler source files.

     Lines starting with '#' are discarded by genassym.sh(8). Lines starting
     with include, ifdef, if, else or endif are preceded with '#' and passed
     otherwise unmodified to the C compiler.

     Lines starting with quote get passed on with the quote command removed.

     The first word after a define command is taken as a CPP identifier and
     the rest of the line has to be a constant C expression. The output of
     genassym.sh(8) will assign the numerical value of this expression to the
     CPP identifier.

     export foo
     is a shorthand for
     define foo foo.

     struct foo
     remembers foo for the member command and does a
     define FOO_SIZEOF sizeof(foo),
     with the structure name converted to upper case.

     member foo
     does a
     define FOO offsetof(<last struct>, foo).
     The two argument form of member, as
     member foo bar
     does a
     define FOO offsetof(<last struct>, bar),
     with its first argument converted to upper case. In the case where struct
     was invoked with an extra argument, as in
     struct foo PREFIX_,
     the first argument of member will be prefixed by the remembered prefix,
     before being converted to upper case.

     union foo
     is similar to the struct command, but applies to a union instead of a
     struct.

     config <ctype> <gcc constraint> <asm print modifier>
     can be used to customize the output of genassym.sh(8).
     When producing C output, values are cast to <ctype> (default: long) be-
     fore they get handed to printf. <gcc constraint> (default: n) is the con-
     straint used in the __asm__ statements. <asm print modifier> (default:
     empty) can be used to force gcc to output operands in different ways than
     normal. The "a" modifier e.g. stops gcc from emitting immediate prefixes
     in front of constants for the i386 and m68k port.

FILES
     /sys/arch/${MACHINE}/${MACHINE}/genassym.cf

SEE ALSO
     genassym.sh(8)

HISTORY
     The first use of genassym.cf files occurred in OpenBSD 2.2. Its use was
     generalized to all ports for OpenBSD 3.0. The union command appeared in
     OpenBSD 3.5.

MirOS BSD #10-current		April 25, 1998				     1
[top]

List of man pages available for MirBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net