fubyte man page on NetBSD

Man page or keyword search:  
man Server   9087 pages
apropos Keyword Search (all sections)
Output format
NetBSD logo
[printable version]

FETCH(9)		 BSD Kernel Developer's Manual		      FETCH(9)

NAME
     fetch, fubyte, fuibyte, fusword, fuswintr, fuword, fuiword — fetch data
     from user-space

SYNOPSIS
     #include <sys/types.h>
     #include <sys/systm.h>

     int
     fubyte(const void *base);

     int
     fusword(const void *base);

     int
     fuswintr(const void *base);

     long
     fuword(const void *base);

DESCRIPTION
     The fetch functions are designed to copy small amounts of data from user-
     space.

     The fetch routines provide the following functionality:

     fubyte()	 Fetches a byte of data from the user-space address base.

     fusword()	 Fetches a short word of data from the user-space address
		 base.

     fuswintr()	 Fetches a short word of data from the user-space address
		 base.	This function is safe to call during an interrupt con‐
		 text.

     fuword()	 Fetches a word of data from the user-space address base.

RETURN VALUES
     The fetch functions return the data fetched or -1 on failure.  Note that
     these functions all do "unsigned" access, and therefore will never sign
     extend byte or short values.  This prevents ambiguity with the error
     return value for all functions except fuword().

SEE ALSO
     copy(9), store(9)

BUGS
     The function fuword() has no way to unambiguously signal an error,
     because the data it reads might legitimately be the same as the -1 used
     to indicate an error.  The other functions do not have this problem
     because the unsigned values returned by those can never match the -1
     error return value.

BSD				January 7, 1996				   BSD
[top]
                             _         _         _ 
                            | |       | |       | |     
                            | |       | |       | |     
                         __ | | __ __ | | __ __ | | __  
                         \ \| |/ / \ \| |/ / \ \| |/ /  
                          \ \ / /   \ \ / /   \ \ / /   
                           \   /     \   /     \   /    
                            \_/       \_/       \_/ 
More information is available in HTML format for server NetBSD

List of man pages available for NetBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net