fubyte man page on Darwin

Man page or keyword search:  
man Server   23457 pages
apropos Keyword Search (all sections)
Output format
Darwin logo
[printable version]

FETCH(9)		 BSD Kernel Developer's Manual		      FETCH(9)

NAME
     fetch, fubyte, fuibyte, fuiword, fulong, fuulong, fuword — fetch data
     from user-space

SYNOPSIS
     #include <sys/types.h>
     #include <sys/time.h>
     #include <sys/systm.h>
     #include <sys/resourcevar.h>

     int
     fubyte(const user_addr_t addr);

     int
     fuibyte(const user_addr_t addr);

     int
     fuiword(user_addr_t addr);

     int64_t
     fulong(user_addr_t addr);

     uint64_t
     fuulong(user_addr_t addr);

     int
     fuword(user_addr_t addr);

DESCRIPTION
     The fetch functions are designed to copy small amounts of data from user-
     space.

     The fetch routines provide the following functionality:

     fubyte()	Fetches a byte of data from the user-space address addr.

     fuibyte()	Fetches a byte of data from the user-space address addr.  This
		function is safe to call during an interrupt context.

     fuiword()	Fetches a word of data from the user-space address addr.  This
		function is safe to call during an interrupt context.

     fulong()	Fetches a long word of data from the user-space address addr.

     fuulong()	Fetches a unsigned long word of data from the user-space
		address addr.

     fuword()	Fetches a word of data from the user-space address addr.

RETURN VALUES
     The fetch functions return the data fetched or -1 on failure.

SEE ALSO
     copy(9), store(9)

BSD			       December 16, 2004			   BSD
[top]

List of man pages available for Darwin

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net