FTPUSERS(4)FTPUSERS(4)NAMEftpusers - file listing users to be disallowed ftp login privileges
The ftpusers file lists users for whom ftp login privileges are disal‐
lowed. Each ftpuser entry is a single line of the form:
where name is the user's login name.
The FTP Server, in.ftpd(1M), reads the ftpusers file. If the login name
of the user matches one of the entries listed, it rejects the login
The ftpusers file has the following default configuration entries:
These entries match the default instantiated entries from passwd(4).
The list of default entries typically contains the superuser root and
other administrative and system application identities.
The root entry is included in the ftpusers file as a security measure
since the default policy is to disallow remote logins for this iden‐
tity. This policy is also set in the default value of the CONSOLE entry
in the /etc/default/login file. See login(1). If you allow root login
privileges by deleting the root entry in ftpusers, you should also mod‐
ify the security policy in /etc/default/login to reflect the site secu‐
rity policy for remote login access by root.
Other default entries are administrative identities that are typically
assumed by system applications but never used for local or remote
login, for example sys and nobody. Since these entries do not have a
valid password field instantiated in shadow(4), no login can be per‐
If a site adds similar administrative or system application identities
in passwd(4) and shadow(4), for example, majordomo, the site should
consider including them in the ftpusers file for a consistent security
Lines that begin with # are treated as comment lines and are ignored.
A file that lists users for whom ftp login privi‐
leges are disallowed.
See /etc/ftpd/ftpusers. This file is deprecated,
although its use is still supported.
shadow password file
See attributes(5) for descriptions of the following attributes:
│ ATTRIBUTE TYPE │ ATTRIBUTE VALUE │
│Interface Stability │ See below. │
The interface stability for /etc/ftpd/ftpusers is Volatile. The inter‐
face stability for /etc/ftpusers is (Obsolete).
SEE ALSOlogin(1), in.ftpd(1M), ftpaccess(4), ftphosts(4), passwd(4), shadow(4),
May 1, 2003 FTPUSERS(4)