FTPCONFIG(1M)FTPCONFIG(1M)NAMEftpconfig - set up anonymous FTP
The ftpconfig script is executed by the super user to set up anonymous
FTP. Anonymous FTP allows users to remotely log on to the FTP server by
specifying the user name ftp or anonymous and the user's email address
as password. The anonymous users are logged on to the FTP Server and
given access to a restricted file area with its own file system root.
See chroot(2). The FTP area has its own minimal system files.
This command will copy and set up all the components needed to operate
an anonymous FTP server, including creating the ftp user account, cre‐
ating device nodes, copying /usr/lib files, and copying timezone data.
The passwd and group files set up have been stripped down to prevent
malicious users from finding login names on the server. The anonymous
file area will be placed under ftpdir. If the ftp user account already
exists, then the current FTP area is used, and the system files in it
are updated. All other files are left untouched. This command should be
run to update the anonymous FTP area's configuration whenever a system
patch is installed, or the system is upgraded.
Create a new or update an existing ftpdir without creating or
updating the ftp user account. Use this option when creating
guest FTP user accounts.
The following operands are supported:
The absolute pathname of the directory under which the anony‐
mous FTP area is set up.
The following exit values are returned:
Improper usage of the command
See attributes(5) for descriptions of the following attributes:
│ ATTRIBUTE TYPE │ ATTRIBUTE VALUE │
│Interface Stability │ Evolving │
SEE ALSOftpaddhost(1M), in.ftpd(1M), useradd(1M), chroot(2), attributes(5)
May 1, 2003 FTPCONFIG(1M)