fstab man page on OpenBSD

Man page or keyword search:  
man Server   11362 pages
apropos Keyword Search (all sections)
Output format
OpenBSD logo
[printable version]

FSTAB(5)		  OpenBSD Programmer's Manual		      FSTAB(5)

NAME
     fstab - static information about the filesystems

SYNOPSIS
     #include <fstab.h>

DESCRIPTION
     The fstab file contains descriptive information about the various file
     systems.  fstab is only read by programs, and not written; it is the duty
     of the system administrator to properly create and maintain this file.
     Each filesystem is described on a separate line; fields on each line are
     separated by tabs or spaces.  Lines beginning with the `#' character are
     comments and are ignored.	The order of records in fstab is important
     because fsck(8) and mount(8) sequentially iterate through fstab doing
     their thing.

     A line has the following format:

	   fs_spec fs_file fs_vfstype fs_mntops fs_freq fs_passno

     The first field, fs_spec, describes the block special device or remote
     filesystem to be mounted.	A block special device may be specified by
     pathname or by disklabel(8) UID (DUID).  For filesystems of type MFS the
     special file name is typically that of the primary swap area; if the
     keyword ``swap'' is used instead of a special file name, default
     configuration parameters are used.	 If a program needs the character
     special file name, the program must create it by appending an `r' after
     the last `/' in the special file name.

     The second field, fs_file, describes the mount point for the filesystem.
     For swap partitions, this field should be specified as ``none''.

     The third field, fs_vfstype, describes the type of the filesystem.	 The
     system currently supports the following types of filesystems:

	   cd9660  An ISO 9660 CD-ROM filesystem.
	   ext2fs  A local Linux compatible ext2fs filesystem.
	   ffs	   A local UNIX filesystem.
	   mfs	   A local memory-based UNIX filesystem.
	   msdos   An MS-DOS FAT filesystem.
	   nfs	   A Sun Microsystems compatible Network File System.
	   ntfs	   An NTFS filesystem.
	   procfs  A local filesystem containing process information.
	   swap	   A disk partition to be used for swapping.
	   udf	   A UDF filesystem.
	   vnd	   A VND image file.

     The fourth field, fs_mntops, describes the mount options associated with
     the filesystem.  It is formatted as a comma separated list of options.
     It contains at least the type of mount (see fs_type below) plus any
     additional options appropriate to the filesystem type.

     The option ``auto'' can be used in the ``noauto'' form to cause a file
     system not to be mounted automatically (with mount -A or mount -a, or at
     system boot time).

     If the options ``userquota'' and/or ``groupquota'' are specified, the
     filesystem is automatically processed by the quotacheck(8) command, and
     user and/or group disk quotas are enabled with quotaon(8).	 By default,
     filesystem quotas are maintained in files named quota.user and
     quota.group which are located at the root of the associated filesystem.
     These defaults may be overridden by putting an equal sign and an
     alternative absolute pathname following the quota option.	Thus, if the
     user quota file for /tmp is stored in /var/quotas/tmp.user, this location
     can be specified as:

	   userquota=/var/quotas/tmp.user

     The type of the mount is extracted from the first parameter of the
     fs_mntops field and stored separately in the fs_type field (it is not
     deleted from the fs_mntops field).	 If fs_type is ``rw'', ``rq'', or
     ``ro'' then the filesystem whose name is given in the fs_file field is
     normally mounted read-write or read-only on the specified special file.
     If fs_type is ``sw'' then the special file is made available as a piece
     of swap space by the swapon(8) command at the end of the system reboot
     procedure.	 The fields other than fs_spec and fs_type are unused.	If
     fs_type is specified as ``xx'' the entry is ignored.  This is useful to
     show disk partitions which are currently unused.

     The fifth field, fs_freq, is used by the -W and -w options of dump(8) to
     recommend which filesystems should be backed up.  The value specifies the
     number of days after which a dump is regarded as being old; if it is not
     present, a value of zero is returned and dump(8) will assume that the
     filesystem does not need to be dumped.

     The sixth field, fs_passno, is used by the fsck(8) program to determine
     the order in which filesystem checks are done at reboot time.  The root
     filesystem should be specified with a fs_passno of 1, and other
     filesystems should have a fs_passno of 2.	Filesystems within a drive
     will be checked sequentially, but filesystems on different drives will be
     checked at the same time to utilize parallelism available in the
     hardware.	If the sixth field is not present or is zero, a value of zero
     is returned and fsck(8) will assume that the filesystem does not need to
     be checked.

     #define FSTAB_RW	     "rw"    /* read/write device */
     #define FSTAB_RQ	     "rq"    /* read/write with quotas *
     #define FSTAB_RO	     "ro"    /* read-only device */
     #define FSTAB_SW	     "sw"    /* swap device */
     #define FSTAB_XX	     "xx"    /* ignore totally */

     struct fstab {
	     char    *fs_spec;	     /* block special device name */
	     char    *fs_file;	     /* filesystem path prefix */
	     char    *fs_vfstype;    /* type of filesystem */
	     char    *fs_mntops;     /* comma separated mount options */
	     char    *fs_type;	     /* rw, rq, ro, sw, or xx */
	     int     fs_freq;	     /* dump frequency, in days */
	     int     fs_passno;	     /* pass number on parallel fsck */
     };

     The proper way to read records from fstab is to use the routines
     getfsent(3), getfsspec(3), and getfsfile(3).

FILES
     /etc/fstab

EXAMPLES
     Here is a sample /etc/fstab file:

	   /dev/sd0a / ffs rw 1 1
	   /dev/sd0e /var ffs rw,nodev,nosuid 1 2
	   #/dev/sd0f /tmp ffs rw,nodev,nosuid 1 2
	   swap /tmp mfs rw,nodev,nosuid,-s=153600 0 0
	   /dev/sd0g /usr ffs rw,nodev 1 2
	   /dev/sd0h /usr/local ffs rw,nodev 1 2
	   /dev/sd0i /home ffs rw,nodev,nosuid 1 2
	   /dev/sd0j /usr/src ffs rw,nodev,nosuid,softdep 1 2
	   /dev/sd1b none swap sw 0 0
	   /dev/cd0a /cdrom cd9660 ro,noauto 0 0
	   5b27c2761a9b0b06.i /mnt/key msdos rw,noauto 0 0
	   server:/export/ports /usr/ports nfs rw,nodev,nosuid,soft,intr 0 0

SEE ALSO
     quota(1), getfsent(3), fsck(8), mount(8), quotacheck(8), quotaon(8)

HISTORY
     The fstab file format appeared in 4.0BSD.

OpenBSD 4.9		      September 28, 2010		   OpenBSD 4.9
[top]

List of man pages available for OpenBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net