fr man page on BSDi

Man page or keyword search:  
man Server   6284 pages
apropos Keyword Search (all sections)
Output format
BSDi logo
[printable version]

FR(4)			    BSD Programmer's Manual			 FR(4)

NAME
     fr - Frame Relay serial line encapsulation

SYNOPSIS
     #include <sys/types.h>
     #include <sys/ioctl.h>
     #include <net/if.h>
     #include <net/if_fr.h>

     options FR

DESCRIPTION
     The FR serial line encapsulation provides a method for transmitting data-
     grams over synchronous serial point-to-point links.  The current FR im-
     plementation includes support for ANSI, FRIF, and CCITT Link Management
     Protocols for both DTE and DCE interfaces.	 DCE support is mainly for
     testing and not fully functional.

     The kernel configuration option FR should be defined to include the rele-
     vant code in the kernel.

     The FR encapsulation options are configurable by the frconfig(8) utility.

     The following interface ioctl(2) requests are specific to Frame Relay:

     FR_SCONFIG struct fr_req *req
	     Set the configuration for the link.  See frconfig(8) for a com-
	     plete description of the various parameters.  See <net/if_fr.h>
	     for a description of the fr_req structure.

     FR_GCONFIG struct fr_req *req
	     Get the configuration for the link.

     FR_SROUTE struct fr_rtreq *rtreq
	     Add a static route between an IPv4 address (and mask) and a DLCI.
	     Normally this is done automatically by using inverse arp, howev-
	     er, if the other side does not support inverse arp this command
	     may be used to force a route.  See <net/if_fr.h> for a descrip-
	     tion of the fr_rtreq structure.

     FR_CROUTE struct fr_rtreq *rtreq
	     Clear a static route between an IPv4 address (and mask) and a DL-
	     CI.

     FR_GROUTE struct fr_mapreq *mapreq
	     Get a list of static routes between IPv4 addresses (and masks)
	     and DLCIs.	 See <net/if_fr.h> for a description of the fr_mapreq
	     structure.

     FR_GMAP struct fr_mapreq *mapreq
	     Get a list of dynamic routes between IPv4 addresses (and masks)
	     and DLCIs.	 These routes are created by automatic inverse arp
	     queries for each discovered DLCI.

     Since synchronous interfaces support more than one link-level protocol,
     FR should be selected before any data will be transmitted through the in-
     terface.  To select FR on synchronous interfaces, the linktype fr parame-
     ter to ifconfig(8) should be used.

SEE ALSO
     ioctl(2),	socket(2),  intro(4),  p2p(4),	frconfig(8),  ifconfig(8),

BUGS
     Currently only IP version 4 transport level is supported.

BSDI BSD/OS			 July 13, 1998				     2
[top]

List of man pages available for BSDi

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net