dir man page on BSDi

Man page or keyword search:  
man Server   6284 pages
apropos Keyword Search (all sections)
Output format
BSDi logo
[printable version]

DIR(5)			    BSD Programmer's Manual			DIR(5)

NAME
     dirent - directory file format

SYNOPSIS
     #include <sys/types.h>
     #include <dirent.h>

DESCRIPTION
     Directories provide a convenient hierarchical method of grouping files
     while obscuring the underlying details of the storage medium.  A directo-
     ry file is differentiated from a plain file by a flag in its inode(5) en-
     try.  It consists of records (directory entries) each of which contains
     information about a file and a pointer to the file itself.	 Directory en-
     tries may contain other directories as well as plain files; such nested
     directories are referred to as subdirectories.  A hierarchy of directo-
     ries and files is formed in this manner and is called a file system (or
     referred to as a file system tree).

     Each directory file contains two special directory entries; one is a
     pointer to the directory itself called dot `.' and the other a pointer to
     its parent directory called dot-dot `..'. Dot and dot-dot are valid path-
     names, however, the system root directory `/', has no parent and dot-dot
     points to itself like dot.

     File system nodes are ordinary directory files on which has been grafted
     a file system object, such as a physical disk or a partitioned area of
     such a disk.  See mount(8) for further information.

     The dirent structure defines the format of directory entries returned by
     the directory(3) C library routines and the getdirentries(2) system call.

     A directory entry begins with a struct dirent, containing its inode num-
     ber, the length of the entry, its type and the length of the name con-
     tained in the entry.  This is followed by the name padded to a 4 byte
     boundary with nul bytes.  All names are nul terminated.  The maximum
     length of a name in a directory is MAXNAMLEN.

     The directory entry format is defined in the include file <dirent.h>:

     struct dirent {
	     u_int32_t d_fileno;       /* file number of entry */
	     u_int16_t d_reclen;       /* length of this record */
	     u_int8_t  d_type;	       /* file type, see below */
	     u_int8_t  d_namlen;       /* length of string in d_name */
     #define MAXNAMLEN	     255       /* name must be no longer than this */
	     char    d_name[MAXNAMLEN + 1];
     };

     /*
      * File types, found in the d_type field.
      */
     #define DT_UNKNOWN	      0
     #define DT_FIFO	      1		     /* Fifo */
     #define DT_CHR	      2		     /* Character device */
     #define DT_DIR	      4		     /* Directory */
     #define DT_BLK	      6		     /* Block device */
     #define DT_REG	      8		     /* Regular file */
     #define DT_LNK	     10		     /* Symbolic link */
     #define DT_SOCK	     12		     /* Socket */
     #define DT_WHT	     14		     /* Whiteout */

     #define d_ino	     d_fileno	     /* backward compatibility */

SEE ALSO
     getdirentries(2),	directory(3),  fs(5),  inode(5)

4.2 Berkeley Distribution	  May 3, 1995				     2
[top]

List of man pages available for BSDi

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net