device_set_driver man page on FreeBSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
FreeBSD logo
[printable version]

DEVICE_SET_DRIVER(9)	 BSD Kernel Developer's Manual	  DEVICE_SET_DRIVER(9)

NAME
     device_set_driver — associate a specific driver with a device node in the
     tree

SYNOPSIS
     #include <sys/param.h>
     #include <sys/bus.h>

     void
     device_set_driver(device_t dev, driver_t *driver);

DESCRIPTION
     This function associates a specific driver with a given device node in
     the tree.	It is typically used in DEVICE_IDENTIFY(9) functions to add
     devices to a bus that does not support doing so automatically, such as
     the ISA bus.

SEE ALSO
     device(9)

AUTHORS
     This manual page was written by M. Warner Losh.

BSD				April 21, 2003				   BSD
[top]

List of man pages available for FreeBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net