device_quiet man page on GhostBSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
GhostBSD logo
[printable version]

DEVICE_QUIET(9)		 BSD Kernel Developer's Manual	       DEVICE_QUIET(9)

NAME
     device_quiet, device_verbose, device_is_quiet — manipulate device quiet
     flag

SYNOPSIS
     #include <sys/param.h>
     #include <sys/bus.h>

     void
     device_quiet(device_t dev);

     void
     device_verbose(device_t dev);

     int
     device_is_quiet(device_t dev);

DESCRIPTION
     Each device has a quiet flag associated with it.  A device is verbose by
     default when it is created but may be quieted to prevent the device iden‐
     tification string to be printed during probe.  To quiet a device, call
     device_quiet(), to re-enable to probe message (to make the message appear
     again, for example after a device_detach(9)) call device_verbose().  To
     test to see if a device is quieted, call device_is_quiet().

SEE ALSO
     device(9)

AUTHORS
     This manual page was written by Doug Rabson.

BSD				 June 21, 1999				   BSD
[top]

List of man pages available for GhostBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net