device_get_children man page on PC-BSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
PC-BSD logo
[printable version]

DEVICE_GET_CHILDREN(9)	 BSD Kernel Developer's Manual	DEVICE_GET_CHILDREN(9)

NAME
     device_get_children — get a list of devices connected to a device

SYNOPSIS
     #include <sys/param.h>
     #include <sys/bus.h>

     int
     device_get_children(device_t dev, device_t **devlistp, int *devcountp);

DESCRIPTION
     Retrieve a list of all device instances currently connected to dev and
     return the list in *devlistp and the count in *devcountp.	The memory
     allocated for the list should be freed using free(*devlistp, M_TEMP).
     devlistp and devcountp are not changed when an error is returned.

RETURN VALUES
     Zero is returned on success, otherwise an appropriate error is returned.

SEE ALSO
     devclass(9), device(9)

AUTHORS
     This manual page was written by Doug Rabson.

BSD				August 23, 2008				   BSD
[top]

List of man pages available for PC-BSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net