devclass_get_devices man page on FreeBSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
FreeBSD logo
[printable version]

DEVCLASS_GET_DEVICES(9)	 BSD Kernel Developer's Manual DEVCLASS_GET_DEVICES(9)

NAME
     devclass_get_devices — get a list of devices in a devclass

SYNOPSIS
     #include <sys/param.h>
     #include <sys/bus.h>

     int
     devclass_get_devices(devclass_t dc, device_t **devlistp, int *devcountp);

DESCRIPTION
     Retrieve a list of all device instances currently in the devclass and
     return the list in *devlistp and the count in *devcountp.	The memory
     allocated for the list should be freed using free(*devlistp, M_TEMP),
     even if *devcountp is 0.

RETURN VALUES
     Zero is returned on success, otherwise an appropriate error is returned.

SEE ALSO
     devclass(9), device(9)

AUTHORS
     This manual page was written by Doug Rabson.

BSD				 May 19, 2005				   BSD
[top]

List of man pages available for FreeBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net