devclass_get_device man page on FreeBSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
FreeBSD logo
[printable version]

DEVCLASS_GET_DEVICE(9)	 BSD Kernel Developer's Manual	DEVCLASS_GET_DEVICE(9)

NAME
     devclass_get_device — translate unit number to device

SYNOPSIS
     #include <sys/param.h>
     #include <sys/bus.h>

     device_t
     devclass_get_device(devclass_t dc, int unit);

DESCRIPTION
     This function retrieves the device instance with the given unit number
     and returns it.

RETURN VALUES
     If the device exists, it is returned, otherwise NULL is returned.

SEE ALSO
     devclass(9), device(9)

AUTHORS
     This manual page was written by Doug Rabson.

BSD				 June 16, 1998				   BSD
[top]

List of man pages available for FreeBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net