devclass_add_driver man page on DragonFly

Man page or keyword search:  
man Server   44335 pages
apropos Keyword Search (all sections)
Output format
DragonFly logo
[printable version]

DEVCLASS_ADD_DRIVER(9)	 BSD Kernel Developer's Manual	DEVCLASS_ADD_DRIVER(9)

NAME
     devclass_add_driver, devclass_delete_driver, devclass_find_driver —
     manipulate the drivers in a devclass

SYNOPSIS
     #include <sys/param.h>
     #include <sys/bus.h>

     int
     devclass_add_driver(devclass_t dc, driver_t *driver);

     int
     devclass_delete_driver(devclass_t dc, driver_t *driver);

     driver_t *
     devclass_find_driver(devclass_t dc, const char *name);

DESCRIPTION
     These functions can be used to add new drivers into the system, remove
     old ones and search for existing ones.  Normally drivers are added auto‐
     matically during system initialisation.

SEE ALSO
     devclass(9), driver(9)

AUTHORS
     This man page was written by Doug Rabson.

BSD				 June 16, 1998				   BSD
[top]

List of man pages available for DragonFly

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net