dev_clone man page on FreeBSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
FreeBSD logo
[printable version]

DEV_CLONE(9)		 BSD Kernel Developer's Manual		  DEV_CLONE(9)

NAME
     dev_clone, drain_dev_clone_events — eventhandler for name-based device
     cloning in devfs

SYNOPSIS
     #include <sys/param.h>
     #include <sys/conf.h>

     void
     clone_handler(void *arg, struct ucred *cr, char *name, int namelen,
	 struct cdev **dev);

     EVENTHANDLER_REGISTER(dev_clone, clone_handler, arg, priority);

     void
     drain_dev_clone_events();

DESCRIPTION
     A device driver may register a listener that will be notified each time a
     name lookup on the devfs(5) mount point fails to find the vnode.  A lis‐
     tener shall be registered for the dev_clone event.	 When called, it is
     supplied with the first argument arg that was specified at handler regis‐
     tration time, appropriate credentials cr, and a name name of length
     namelen that we look for.	If the handler decides that the name is appro‐
     priate and wants to create the device that will be associated with the
     name, it should return it to devfs in the dev argument.

     The drain_dev_clone_events() function is a barrier.  It is guaranteed
     that all calls to eventhandlers for dev_clone that were started before
     drain_dev_clone_events() call, are finished before it returns control.

SEE ALSO
     devfs(5), namei(9)

BSD				January 3, 2009				   BSD
[top]

List of man pages available for FreeBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net