ddi_dma_get_attr man page on OpenIndiana

Man page or keyword search:  
man Server   20441 pages
apropos Keyword Search (all sections)
Output format
OpenIndiana logo
[printable version]

ddi_dma_get_attr(9F)	 Kernel Functions for Drivers	  ddi_dma_get_attr(9F)

NAME
       ddi_dma_get_attr	 -  get	 the device DMA attribute structure from a DMA
       handle

SYNOPSIS
       #include <sys/ddi.h>
       #include <sys/sunddi.h>

       int ddi_dma_get_attr(ddi_dma_handle_t handle, ddi_dma_attr_t *attrp);

INTERFACE LEVEL
       Solaris DDI specific (Solaris DDI). This interface is obsolete.

PARAMETERS
       handle	 The handle filled in by a call to ddi_dma_alloc_handle(9F).

       attrp	 Pointer to a buffer suitable  for  holding  a	DMA  attribute
		 structure. See ddi_dma_attr(9S).

DESCRIPTION
       ddi_dma_get_attr()  is  used  to get a ddi_dma_attr(9S) structure. This
       structure describes the attributes of the DMA data path	to  which  any
       memory object bound to the given handle will be subject.

RETURN VALUES
       DDI_SUCCESS	  Successfully passed back attribute structure in buf‐
			  fer pointed to by attrp.

       DDI_DMA_BADATTR	  A valid attribute  structure	could  not  be	passed
			  back.

CONTEXT
       ddi_dma_get_attr() can be called from any context.

ATTRIBUTES
       See attributes(5) for descriptions of the following attributes:

       ┌─────────────────────────────┬─────────────────────────────┐
       │      ATTRIBUTE TYPE	     │	    ATTRIBUTE VALUE	   │
       ├─────────────────────────────┼─────────────────────────────┤
       │Interface Stability	     │Obsolete			   │
       └─────────────────────────────┴─────────────────────────────┘

SEE ALSO
       ddi_dma_alloc_handle(9F), ddi_dma_attr(9S)

SunOS 5.11			  12 Oct 2005		  ddi_dma_get_attr(9F)
[top]

List of man pages available for OpenIndiana

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net