ddi_dev_nintrs man page on SunOS

Man page or keyword search:  
man Server   20652 pages
apropos Keyword Search (all sections)
Output format
SunOS logo
[printable version]

ddi_dev_nintrs(9F)	 Kernel Functions for Drivers	    ddi_dev_nintrs(9F)

NAME
       ddi_dev_nintrs - return the number of interrupt specifications a device
       has

SYNOPSIS
       #include <sys/conf.h>
       #include <sys/ddi.h>
       #include <sys/sunddi.h>

       int ddi_dev_nintrs(dev_info_t *dip, int *resultp);

INTERFACE LEVEL
       Solaris DDI specific (Solaris DDI). This interface is obsolete. Use the
       new  interrupt  interfaces  referenced  in  Intro(9F). Refer to Writing
       Device Drivers for more information.

DESCRIPTION
       The ddi_dev_nintrs() function returns the number of interrupt  specifi‐
       cations a device has in *resultp.

RETURN VALUES
       The ddi_dev_nintrs() function returns:

       DDI_SUCCESS     A successful return. The number of interrupt specifica‐
		       tions that the device has is set in resultp.

       DDI_FAILURE     The device has no interrupt specifications.

CONTEXT
       The ddi_dev_nintrs() function can be called from	 user,	interrupt,  or
       kernel context.

ATTRIBUTES
       See attributes(5) for descriptions of the following attributes:

       ┌─────────────────────────────┬─────────────────────────────┐
       │      ATTRIBUTE TYPE	     │	    ATTRIBUTE VALUE	   │
       ├─────────────────────────────┼─────────────────────────────┤
       │Interface Stability	     │Obsolete			   │
       └─────────────────────────────┴─────────────────────────────┘

SEE ALSO
       isa(4),	 sbus(4),  ddi_add_intr(9F),  ddi_dev_nregs(9F),  ddi_dev_reg‐
       size(9F), Intro(9F)

       Writing Device Drivers

SunOS 5.10			  16 Jan 2006		    ddi_dev_nintrs(9F)
[top]

List of man pages available for SunOS

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net