cpu_coredump man page on NetBSD

Man page or keyword search:  
man Server   9087 pages
apropos Keyword Search (all sections)
Output format
NetBSD logo
[printable version]

CPU_COREDUMP(9)		 BSD Kernel Developer's Manual	       CPU_COREDUMP(9)

NAME
     cpu_coredump — machine-dependent process core dump interface

SYNOPSIS
     #include <sys/signalvar.h>

     int
     cpu_coredump(struct lwp *l, void *iocookie, struct core *chdr);

     int
     cpu_coredump32(struct lwp *l, void *iocookie, struct core32 *chdr);

DESCRIPTION
     cpu_coredump() is the machine-dependent interface invoked by machine-
     independent code to dump the machine-dependent header information at the
     start of a process core dump.  The header information primarily consists
     of the CPU and floating-point registers.  l is the lwp structure of the
     thread being dumped.  iocookie is an opaque pointer to be passed to
     coredump_write().	Information about the machine-dependent header sec‐
     tions are returned in chdr.

     cpu_coredump() returns 0 on success and an appropriate error code on
     failure.

CODE REFERENCES
     Process core dumps are initiated within the file sys/kern/kern_sig.c.
     Process core dumps for ELF NetBSD binaries are performed within the files
     sys/kern/core_elf32.c or sys/kern/core_elf64.c.  Process core dumps for
     other NetBSD binaries are performed within the file
     sys/kern/core_netbsd.c.

SEE ALSO
     coredump_write(9)

BSD			       December 24, 2005			   BSD
[top]
                             _         _         _ 
                            | |       | |       | |     
                            | |       | |       | |     
                         __ | | __ __ | | __ __ | | __  
                         \ \| |/ / \ \| |/ / \ \| |/ /  
                          \ \ / /   \ \ / /   \ \ / /   
                           \   /     \   /     \   /    
                            \_/       \_/       \_/ 
More information is available in HTML format for server NetBSD

List of man pages available for NetBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net