clnp man page on 4.4BSD

Printed from http://www.polarhome.com/service/man/?qf=clnp&af=0&tf=2&of=4.4BSD

CLNP(4)			 BSD Kernel Interfaces Manual		       CLNP(4)

NAME
     clnp — Connectionless-Mode Network Protocol

SYNOPSIS
     #include <sys/socket.h>
     #include <netiso/iso.h>
     #include <netiso/clnp.h>

     int
     socket(AF_ISO, SOCK_RAW, 0);

DESCRIPTION
     CLNP is the connectionless-mode network protocol used by the connection‐
     less-mode network service. This protocol is specified in ISO 8473.	 It
     may be accessed through a “raw socket” for debugging purposes only.  CLNP
     sockets are connectionless, and are normally used with the sendto and
     recvfrom calls, though the connect(2) call may also be used to fix the
     destination for future packets (in which case the read(2) or recv(2) and
     write(2) or send(2) system calls may be used).

     Outgoing packets automatically have a CLNP header prepended to them.
     Incoming packets received by the user contain the full CLNP header.  The
     following setsockopt options apply to CLNP:

     CLNPOPT_FLAGS  Sets the flags which are passed to clnp when sending a
		    datagram.  Valid flags are:

			  CLNP_NO_SEG	 Do not allow segmentation
			  CLNP_NO_ER	 Suppress ER pdus
			  CLNP_NO_CKSUM	 Do not generate the CLNP checksum

     CLNPOPT_OPTS   Sets CLNP options. The options must be formatted exactly
		    as specified by ISO 8473, section 7.5 “Options Part.” Once
		    an option has been set, it will be sent on all packets
		    until a different option is set.

CONGESTION EXPERIENCE BIT
     Whenever a packet is transmitted, the globally unique quality of service
     option is added to the packet. The sequencing preferred bit and the low
     transit delay bit are set in this option.

     If a packet is forwarded containing the globally unique quality of ser‐
     vice option, and the interface through which the packet will be transmit‐
     ted has a queue length greater than congest_threshold, then the conges‐
     tion experienced bit is set in the quality of service option.

     The threshold value stored in congest_threshold may be tuned.

     When a packet is received with the globally unique quality of service
     option present, and the congestion experienced bit is set, then the
     transport congestion control function is called.

DIAGNOSTICS
     A socket operation may fail with one of the following errors returned:

     [EISCONN]	      When trying to establish a connection on a socket which
		      already has one, or when trying to send a datagram with
		      the destination address specified and the socket is
		      already connected;

     [ENOTCONN]	      When trying to send a datagram, but no destination
		      address is specified, and the socket hasn't been con‐
		      nected;

     [ENOBUFS]	      When the system runs out of memory for an internal data
		      structure;

     [EADDRNOTAVAIL]  When an attempt is made to create a socket with a net‐
		      work address for which no network interface exists;

     [EHOSTUNREACH]   When trying to send a datagram, but no route to the des‐
		      tination address exists.

     [EINVAL]	      When specifying unsupported options.

SEE ALSO
     send(2), recv(2), intro(4), iso(4)

BUGS
     Packets are sent with the type code of 0x1d (technically an invalid
     packet type) for lack of a better way to identify raw CLNP packets.

     No more than MLEN bytes of options can be specified.

BSD				 April 2, 1994				   BSD
[top]

List of man pages available for 4.4BSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net