CHECK-PERMISSIONS(1M)CHECK-PERMISSIONS(1M)NAMEcheck-permissions - check permissions on mail rerouting files
The check-permissions script is intended as a migration aid for send‐
mail(1M). It checks the /etc/mail/sendmail.cf file for all configured
alias files, and checks the alias files for :include: files. It also
checks for certain .forward files. For each file that check-permissions
checks, it verifies that none of the parent directories are group- or
world-writable. If any directories are overly permissive, it is
reported. Otherwise it reports that no unsafe directories were found.
As to which .forward files are checked, it depends on the arguments
included on the command line. If no argument is given, the current
user's home directory is checked for the presence of a .forward file.
If any arguments are given, they are assumed to be valid logins, and
the home directory of each one is checked.
If the special argument ALL is given, the passwd entry in the
/etc/nsswitch.conf file is checked, and all password entries that can
be obtained through the switch file are checked. In large domains, this
can be time-consuming.
The following operands are supported:
Where login is a valid user name, checks the home directory
Checks the home directory of all users.
Defines environment for sendmail
Ascii mail aliases file
See attributes(5) for descriptions of the following attributes:
│ ATTRIBUTE TYPE │ ATTRIBUTE VALUE │
│Interface Stability │ Evolving │
SEE ALSOgetent(1M), sendmail(1M), aliases(4), attributes(5)
Nov 10, 2003 CHECK-PERMISSIONS(1M)