bios_sigsearch man page on DragonFly

Man page or keyword search:  
man Server   44335 pages
apropos Keyword Search (all sections)
Output format
DragonFly logo
[printable version]

BIOS(9)			 BSD Kernel Developer's Manual		       BIOS(9)

NAME
     bios_sigsearch, bios32_SDlookup, bios32, BIOS_PADDRTOVADDR,
     BIOS_VADDRTOPADDR — interact with PC BIOS

SYNOPSIS
     #include <sys/types.h>
     #include <machine/pc/bios.h>

     u_int32_t
     bios_sigsearch(u_int32_t start, u_char *sig, int siglen, int paralen,
	 int sigofs);

     int
     bios32_SDlookup(struct bios32_SDentry *ent);

     void
     bios32(caddr_t entry, struct bios32_args *args);

     BIOS_PADDRTOVADDR(addr);

     BIOS_VADDRTOPADDR(addr);

     extern struct bios32_SDentry PCIbios;
     extern struct SMBIOS_table SMBIOStable;
     extern struct DMI_table DMItable;

DESCRIPTION
     These functions provide a general-purpose interface for dealing with the
     BIOS functions and data encountered on x86 PC-architecture systems.

     bios_sigsearch()	  Searches the BIOS address space for a service signa‐
			  ture, usually an uppercase ASCII sequence surrounded
			  by underscores.  The search begins at start, or at
			  the beginning of the BIOS if start is zero.  siglen
			  bytes of the BIOS image and sig are compared at
			  sigofs bytes offset from the current location.  If
			  no match is found, the current location is incre‐
			  mented by paralen bytes and the search repeated.  If
			  the signature is found, its effective physical
			  address is returned.	If no signature is found, zero
			  is returned.

     BIOS_VADDRTOPADDR()  Returns the effective physical address which corre‐
			  sponds to the kernel virtual address addr.

     BIOS_PADDRTOVADDR()  Returns the kernel virtual address which corresponds
			  to the effective physical address addr.

     SMBIOStable	  If not NULL, points to a struct SMBIOS_table struc‐
			  ture containing information read from the System
			  Management BIOS table during system startup.

     DMItable		  If not NULL, points to a struct DMI_table structure
			  containing information read from the Desktop Manage‐
			  ment Interface parameter table during system
			  startup.

BIOS32
     At system startup, the BIOS is scanned for the BIOS32 Service Directory
     (part of the PCI specification), and the existence of the directory is
     recorded.	This can then be used to locate other services.

     bios32_SDlookup()	  Attempts to locate the BIOS32 service matching the
			  4-byte identifier passed in the ident field of the
			  ent argument.

     bios32()		  Calls a bios32 function.  This presumes that the
			  function is capable of working within the kernel
			  segment (normally the case).	The virtual address of
			  the entrypoint is supplied in entry and the register
			  arguments to the function are supplied in args.

     PCIbios		  If not NULL, points to a struct bios32_SDentry
			  structure describing the PCI BIOS entrypoint which
			  was found during system startup.

BSD				August 1, 1997				   BSD
[top]

List of man pages available for DragonFly

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net