bad144 man page on BSDi

Man page or keyword search:  
man Server   6284 pages
apropos Keyword Search (all sections)
Output format
BSDi logo
[printable version]

BAD144(5)		    BSD Programmer's Manual		     BAD144(5)

NAME
     bad144 - DEC STD 144 bad block format

SYNOPSIS
     #include <sys/types.h>
     #include <sys/dkbad.h>

DESCRIPTION
     The bad144 format is used by some disk drivers to provide replacement
     sectors for faulty areas on a drive.  Such drivers include the wd(4)
     driver on Intel (R) systems and the hk(4) and hp(4) drivers on VAX (R)
     systems.

     The bad sector information is located in the first 5 even numbered sec-
     tors of the last track of the disk pack.  There are five identical copies
     of the information, described by the dkbad structure.

     Replacement sectors are allocated starting with the first sector before
     the bad sector information and working backwards towards the beginning of
     the disk.	A maximum of 126 bad sectors are supported.  The position of
     the bad sector in the bad sector table determines the replacement sector
     to which it corresponds.  The bad sectors must be listed in ascending or-
     der.

     The bad sector information and replacement sectors are conventionally on-
     ly accessible through the ``c'' file system partition of the disk.	 If
     that partition is used for a file system, the user is responsible for
     making sure that it does not overlap the bad sector information or any
     replacement sectors.  Thus, one track plus 126 sectors must be reserved
     to allow use of all of the possible bad sector replacements.

     The bad sector structure is as follows:

     struct dkbad {
	     long    bt_csn;	      /* cartridge serial number */
	     u_short bt_mbz;	      /* unused; should be 0 */
	     u_short bt_flag;	      /* -1 => alignment cartridge */
	     struct bt_bad {
		   u_short bt_cyl;    /* bad sector cylinder number */
		   u_short bt_trksec; /* track and sector number */
	     } bt_bad[126];
     };

     Unused slots in the bt_bad array are filled with all bits set, a puta-
     tively illegal value.

SEE ALSO
     diskdefect(8)

BSDI BSD/OS			 April 2, 1995				     1
[top]

List of man pages available for BSDi

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net