arp_ifinit man page on NetBSD

Man page or keyword search:  
man Server   9087 pages
apropos Keyword Search (all sections)
Output format
NetBSD logo
[printable version]

ARP(9)			 BSD Kernel Developer's Manual			ARP(9)

NAME
     arp, arp_ifinit, arpresolve, arpintr — externally visible ARP functions

SYNOPSIS
     #include <netinet/if_inarp.h>

     void
     arp_ifinit(struct ifnet *ifp, struct ifaddr *ifa);

     int
     arpresolve(struct ifnet *ifp, struct rtentry *rt, struct mbuf *m,
	 struct sockaddr *dst, u_char *desten);

     void
     arpintr();

DESCRIPTION
     The arp functions provide the interface between the arp module and the
     network drivers which need arp functionality.  Such drivers must request
     the arp attribute in their "files" declaration.

     arp_ifinit()  Sets up the arp specific fields in ifa.  Additionally, it
		   sends out a gratuitous arp request on ifp, so that other
		   machines are warned that we have a (new) address and dupli‐
		   cate addresses can be detected.

		   You must call this in your drivers' ioctl function when you
		   get a SIOCSIFADDR request with an AF_INET address family.

     arpresolve()  is called by network output functions to resolve an IPv4
		   address.  If no rt is given, a new one is looked up or cre‐
		   ated.  If the passed or found rt does not contain a valid
		   gateway link level address, a pointer to the packet in m is
		   stored in the route entry, possibly replacing older stored
		   packets, and an arp request is sent instead.	 When an arp
		   reply is received, the last held packet is send.  Other‐
		   wise, the looked up address is returned and written into
		   the storage desten points to.  arpresolve() returns 1, if a
		   valid address was stored to desten, and the packet can be
		   sent immediately.  Else a 0 is returned.

     arpintr()	   When an arp packet is received, the network driver (class)
		   input interrupt handler queues the packet on the arpintrq
		   queue, and requests an arpintr() soft interrupt callback.
		   arpintr() dequeues the packets, performs sanity checks and
		   calls (for IPv4 arp packets, which are the only ones sup‐
		   ported currently) the in_arpinput() function.
		   in_arpinput() either generates a reply to request packets,
		   and adds the sender address translation to the routing ta‐
		   ble, if a matching route entry is found.  If the route
		   entry contained a pointer to a held packet, that packet is
		   sent.

SEE ALSO
     ether_ifattach(9)

     Plummer, D., "RFC826", An Ethernet Address Resolution Protocol.

STANDARDS
     RFC 826

HISTORY
     Rewritten to support other than Ethernet link level addresses in
     NetBSD 1.3.

AUTHORS
     UCB CSRG (original implementation)
     Ignatios Souvatzis (support for non-Ethernet)

CODE REFERENCES
     The ARP code is implemented in sys/net/if_arp.h, sys/netinet/if_inarp.h
     and sys/netinet/if_arp.c.

BSD				 March 3, 1997				   BSD
[top]
                             _         _         _ 
                            | |       | |       | |     
                            | |       | |       | |     
                         __ | | __ __ | | __ __ | | __  
                         \ \| |/ / \ \| |/ / \ \| |/ /  
                          \ \ / /   \ \ / /   \ \ / /   
                           \   /     \   /     \   /    
                            \_/       \_/       \_/ 
More information is available in HTML format for server NetBSD

List of man pages available for NetBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net