APSFILTERRC(5) BSD File Formats Manual APSFILTERRC(5)NAMEapsfilterrc — configuration file for magic print filter
Apsfilterrc is a configuration file for printers controlled by the
apsfilter(1) magic filter.
Every apsfilter printer in printcap(5) has an apsfilterrc file of its
There is one global apsfilterrc file that controls print characteristics
for all printer. The printer-specific apsfilterrc files have preference
over the global one.
Reasons for using an apsfilterrc file are if it turns out, that you have
to type in some commandline options too often or if an application is
unable to parameterize the print command, so that you have to hardcode
the print characteristic for such dumb applications.
An enhancement to this concept are user-specific config files, that have
preference over the global and the printer-specific config file. This
allows configuration of print characteristics on a per-user basis.
You should make use of user-specific config files instead of using the
deprecated USE_USER_CODE variable, which compromises system security and
is only an option on a single-user machine, see below.
QUALITY Select print quality (draft, lo|low, med|medium,
SWEEP Print uni- or bidirectional (uni, bi).
MEDIA Select paper type (plain, coated, glossy, premium,
COLOR Select color mode (color|colour, gray|grey, mono).
METHOD Choose apsfilters method of data processing (auto,
ascii, raw). Automatic file type recognition and auto‐
matic conversion to Postscript is apsfilters default
processing method. If you want to print mostly files `as
is', you can set the default to 'raw', this disables any
kind of file type recognition and conversion. If you
want to print mostly everything as ASCII text, then you
can set this option to 'ascii'.
PAPERSIZE Set the default paper size (a3, a4, legal, ledger,
ASCII_FILTER Text file filter to use, when printing ASCII documents
(a2ps, mpage, enscript, recode).
PAPERTRAY Paper feed tray number (tray0...tray9).
PRETTY_PRINTING a2ps highlight level for pretty-printing when using a2ps
or enscript as ascii filter (0, 1, 2). See also
ASCII_HEADER Whether you want headers in your text prints when using
a2ps, mpage or enscript as ascii filter (header,
ASCII_BORDER Whether you want borders in your text prints when using
a2ps, mpage or enscript as ascii filter (border, nobor‐
Pages per sheet (1pps, 2pps, 4pps, 8pps).
Paper orientation (landscape, portrait).
PS_BOOK Output pages in "book" format, implies commandline
options "2pps,duplex,shortbind". Related options:
PS_NUP, ASCII_PPS, DUPLEX, BINDING.
DUPLEX Whether to use duplex mode or not (duplex, simplex).
BINDING Paper binding edge (shortbind, longbind).
COPIES Number of copies (copies=N).
USE_USER_CODE Enabling this option is a big potential security hole
!!! If you don't understand this, DO NOT USE IT. It
makes user manageable apsfilterrc files possible which
will be sourced (included/executed) during runtime of a
printjob under the permissions of the calling process
(lpd). This option is only valid for typical "single-
user" systems, where a user wants direct access to an
apsfilterrc without having to become root to make
changes. A more conveniant way on a multi-user system,
where security is an issue, is that a system administra‐
tor creates user-specific apsfilterrc files. Additional
informations can be found in the apsfilter handbook and
in the apsfilterrc file together with some examples.
apsfilter global config file, settings are overwriteable
by more specific printer config files, see below.
apsfilter config file on a per printer queue basis. This
file has preference over the global config file.
apsfilter config file on a per user basis (per print
queue). This file has preference over the global and the
printer queue specific config file.
A user defineable config file on a per printer queue
basis. This file has preference over the global, the
printer queue specific and the central per user config
file, which is administered by a system administrator.
Enabling this has a deep impact on your systems secu‐
rity, should NOT be used, especially on multi-user sys‐
tems and is therefore disabled by default. See comments
to USE_USER_CODE variable.
SEE ALSOapsfilter(1), printcap(5)BUGS
See apsfilter software center - http://www.apsfilter.org/ - for new ver‐
sions, bugfixes and known bugs.
Please use the new tool apsfilter-bug(1) to release bug- or problem
reports. It automatically presents you a form in an editor window which
asks you some standard questions. If you save and quit the editor ses‐
sion, then this report is sent automatically via e-mail to the proper
If apsfilter fails to print something or prints it in a way you wouldn't
expect and you want to report an apsfilter error then please save the
debugging output of one print session using the new aps2file(1) utility
by typing aps2file -D -Z options file > /dev/null 2> file.debug and
including the debugging output in the file file.debug into the edit ses‐
sion of the apsfilter-bug utility, so that it is included into the mail
to the apsfilter mailinglist.
Please note that you need to run /bin/sh (Bourne Shell), bash or a com‐
patible shell, so that the above mentioned output redirection works.
Under C-shell (/bin/csh) or tcsh it would't work. If you don't know, then
simply make sure you use the Bournce shell by typing /bin/sh or bash,
then you should have no problems with redirection of stdout and stderr (>
/dev/null 2> file.debug).
See official apsfilter homepage
http://www.apsfilter.org/handbook.html Apsfilter Handbook including the
Frequently Asked Questions (FAQ)
Please send questions to the official apsfilter help channel
firstname.lastname@example.org. The above section BUGS and the file
HOWTO-BUGREPORTS tells you how to report bugs. If you want to know how
to troubleshoot your apsfilter installation, please read the manpage
aps2file(1) and apsfilter-bug(1) as well as the Apsfilter Handbook care‐
Apsfilter developement started in 1994.
The apsfilterrc file on a "per printer queue" basis appeared in apsfilter
BSD April 08, 2000 BSD