agpgart man page on DragonFly

Man page or keyword search:  
man Server   44335 pages
apropos Keyword Search (all sections)
Output format
DragonFly logo
[printable version]

AGP(4)			 BSD Kernel Interfaces Manual			AGP(4)

NAME
     agp — accelerated graphics port driver

SYNOPSIS
     To compile this driver into the kernel, place the following lines in your
     kernel configuration file:

	   device agp

     Alternatively, to load the driver as a module at boot time, place the
     following line in loader.conf(5):

	   agp_load="YES"

DESCRIPTION
     The agp driver provides machine-independent support for the accelerated
     graphics port (AGP) found on many PC-based and PCI systems.  The AGP
     specification was designed by Intel.

     The AGP chipset is positioned between the PCI-Host bridge and the graph‐
     ics accelerator to provide a high-performance dedicated graphics bus for
     moving large amounts of data directly from host memory to the graphics
     accelerator.  The specification currently supports a peak bandwidth of
     528 MB/s.	AGP uses a Graphics Address Remapping Table (GART) to provide
     a physically-contiguous view of scattered pages in host memory for DMA
     transfers.

     The agp driver supports the following chipsets:

	   -   ALI M1541, M1621 and M1671 host to AGP bridges
	   -   AMD 751, 761 and 762 host to AGP bridges
	   -   AMD 8151 AGP graphics tunnel
	   -   ATI RS100, RS200, RS250 and RS300 AGP bridges
	   -   Intel i810, i815, i830, 845, 852, 855, 865, 915, 945, 946 and
	       965 series SVGA controllers
	   -   Intel 82443LX, 82443BX, 82443GX, i820, i840, i845, i845G, i850,
	       i855, i855GM, i860, i865, i875P, E7205 and E7505 host to AGP
	       bridges
	   -   Nvidia nForce, nForce2 and nForce3 AGP controllers
	   -   SiS 530, 540, 550, 620, 630, 645, 645DX, 648, 650, 651, 655,
	       661, 730, 735, 740, 741, 745, 746, 755, 760 and 5591 host to
	       AGP bridges
	   -   ULi M1689 AGP controller
	   -   VIa 3238, 3296, 82C597, 82C598, 82C691, 82C694X, 82C8363, 8235,
	       8237, 8361, 8367, 8371, 8377, 8380, 8385, 8501, 8601, 862x,
	       8633, 8653, 8703, 8753, 8754, 8763, 8783, KT880, K8T800Pro,
	       PM800, PM880, PN800, PN880, PT880, XM266 and XN266 host to PCI
	       bridges

     The agp driver also provides an interface to user processes for use by X
     servers.  A user process communicates to the device initially by means of
     ioctl(2) calls performed on /dev/agpgart.	All calls and related struc‐
     tures are defined in <sys/agpio.h>.  The calls supported are:

     AGPIOC_INFO
	     Returns state of the agp system.  The result is a pointer to the
	     following structure:

	     typedef struct _agp_info {
		     agp_version version;    /* version of the driver	    */
		     uint32_t bridge_id;     /* bridge vendor/device	    */
		     uint32_t agp_mode;	     /* mode info of bridge	    */
		     off_t aper_base;	     /* base of aperture	    */
		     size_t aper_size;	     /* size of aperture	    */
		     size_t pg_total;	     /* max pages (swap + system)   */
		     size_t pg_system;	     /* max pages (system)	    */
		     size_t pg_used;	     /* current pages used	    */
	     } agp_info;

     AGPIOC_ACQUIRE
	     Acquire control of the AGP chipset for use by this client.
	     Returns EBUSY if the AGP chipset is already acquired by another
	     client.

     AGPIOC_RELEASE
	     Release control of the AGP chipset.  This does not unbind or free
	     any allocated memory, which is the responsibility of the client
	     to handle if necessary.

     AGPIOC_SETUP
	     Enable the AGP hardware with the relevant mode.  This ioctl(2)
	     takes the following structure:

	     typedef struct _agp_setup {
		     uint32_t agp_mode;	    /* mode info of bridge	    */
	     } agp_setup;

	     The mode bits are defined in <sys/agpio.h>.

     AGPIOC_ALLOCATE
	     Allocate physical memory suitable for mapping into the AGP aper‐
	     ture.  This ioctl(2) takes the following structure:

	     typedef struct _agp_allocate {
		     int key;		    /* tag of allocation	    */
		     size_t pg_count;	    /* number of pages		    */
		     uint32_t type;	    /* 0 == normal, other devspec   */
		     paddr_t physical;	    /* device specific (some devices
					     * need a phys address of the
					     * actual page behind the gatt
					     * table)			    */
	     } agp_allocate;

	     Returns a handle to the allocated memory.

     AGPIOC_DEALLOCATE
	     Free the previously allocated memory associated with the handle
	     passed.

     AGPIOC_BIND
	     Bind the allocated memory at given offset with the AGP aperture.
	     Returns EINVAL if the memory is already bound or the offset is
	     not at AGP page boundary.	This ioctl(2) takes the following
	     structure:

	     typedef struct _agp_bind {
		     int key;		    /* tag of allocation	    */
		     off_t pg_start;	    /* starting page to populate    */
	     } agp_bind;

	     The tag of allocation is the handle returned by AGPIOC_ALLOCATE.

     AGPIOC_UNBIND
	     Unbind memory from the AGP aperture.  Returns EINVAL if the mem‐
	     ory is not bound.	This ioctl(2) takes the following structure:

	     typedef struct _agp_unbind {
		     int key;		    /* tag of allocation	    */
		     uint32_t priority;	    /* priority for paging out	    */
	     } agp_unbind;

FILES
     /dev/agpgart  AGP GART device special file

EXAMPLES
     This short code fragment is an example of opening the AGP device and per‐
     forming some basic operations:

     #include <stdio.h>
     #include <sys/types.h>
     #include <sys/ioctl.h>
     #include <sys/agpio.h>
     #include <fcntl.h>
     #include <err.h>

     int
     main(int argc, char **argv)
     {
	     int fd;
	     agp_info info;
	     agp_allocate alloc;
	     agp_setup setup;
	     agp_bind bind;
	     agp_unbind unbind;

	     fd = open("/dev/agpgart", O_RDWR);
	     if (fd < 0)
		     err(1, "open");

	     if (ioctl(fd, AGPIOC_INFO, &info) < 0)
		     err(2, "ioctl AGPIOC_INFO");

	     printf("version:	     %u.%u\n", info.version.major,
		 info.version.minor);

	     printf("id:	     %x\n", info.bridge_id);
	     printf("mode:	     %x\n", info.agp_mode);
	     printf("base:	     %x\n", info.aper_base);
	     printf("size:	     %uM\n", info.aper_size);
	     printf("total mem:	     %u\n", info.pg_total);
	     printf("system mem:     %u\n", info.pg_system);
	     printf("used mem:	     %u\n\n", info.pg_used);

	     setup.agp_mode = info.agp_mode;

	     if (ioctl(fd, AGPIOC_SETUP, &setup) < 0)
		     err(3, "ioctl AGPIOC_SETUP");

	     if (ioctl(fd, AGPIOC_ACQUIRE, 0) < 0)
		     err(3, "ioctl AGPIOC_ACQUIRE");

	     alloc.type = 0;
	     alloc.pg_count = 64;

	     if (ioctl(fd, AGPIOC_ALLOCATE, &alloc) < 0)
		     err(4, "ioctl AGPIOC_ALLOCATE");

	     printf("alloc key %d, paddr %x\n", alloc.key, alloc.physical);
	     if (ioctl(fd, AGPIOC_INFO, &info) < 0)
		     err(5, "ioctl AGPIOC_INFO");

	     bind.key = alloc.key;
	     bind.pg_start = 0x1000;

	     if (ioctl(fd, AGPIOC_BIND, &bind) < 0)
		     err(6, "ioctl AGPIOC_BIND");

	     printf("used mem now:   %u\n\n", info.pg_used);

	     unbind.key = alloc.key;
	     unbind.priority = 0;

	     if (ioctl(fd, AGPIOC_UNBIND, &unbind) < 0)
		     err(6, "ioctl AGPIOC_BIND");

	     if (ioctl(fd, AGPIOC_DEALLOCATE, &alloc.key) < 0)
		     err(6, "ioctl AGPIOC_DEALLOCATE");

	     if (ioctl(fd, AGPIOC_RELEASE, 0) < 0)
		     err(7, "ioctl AGPIOC_RELEASE");

	     close(fd);

	     printf("agp test successful\n");

	     return 0;
     }

SEE ALSO
     ioctl(2)

HISTORY
     The agp driver first appeared in FreeBSD 4.1.

BSD			      September 12, 2007			   BSD
[top]

List of man pages available for DragonFly

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net