accf_data man page on FreeBSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
FreeBSD logo
[printable version]

ACCF_DATA(9)		 BSD Kernel Developer's Manual		  ACCF_DATA(9)

NAME
     accf_data — buffer incoming connections until data arrives

SYNOPSIS
     options INET
     options ACCEPT_FILTER_DATA
     kldload accf_data

DESCRIPTION
     This is a filter to be placed on a socket that will be using accept() to
     receive incoming connections.

     It prevents the application from receiving the connected descriptor via
     accept() until data arrives on the connection.

     The ACCEPT_FILTER_DATA kernel option is also a module that can be enabled
     at runtime via kldload(8) if the INET option has been compiled into the
     kernel.

EXAMPLES
     Assuming ACCEPT_FILTER_DATA has been included in the kernel config file
     or the accf_data module has been loaded, this will enable the data accept
     filter on the socket sok.

	     struct accept_filter_arg afa;

	     bzero(&afa, sizeof(afa));
	     strcpy(afa.af_name, "dataready");
	     setsockopt(sok, SOL_SOCKET, SO_ACCEPTFILTER, &afa, sizeof(afa));

SEE ALSO
     setsockopt(2), accept_filter(9), accf_dns(9) accf_http(9)

HISTORY
     The accept filter mechanism and the accf_data filter were introduced in
     FreeBSD 4.0.

AUTHORS
     This manual page and the filter were written by Alfred Perlstein.

BSD			       November 15, 2000			   BSD
[top]

List of man pages available for FreeBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net