SYSCALL_MODULE man page on FreeBSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
FreeBSD logo
[printable version]

SYSCALL_MODULE(9)	 BSD Kernel Developer's Manual	     SYSCALL_MODULE(9)

NAME
     SYSCALL_MODULE — syscall kernel module declaration macro

SYNOPSIS
     #include <sys/param.h>
     #include <sys/kernel.h>
     #include <sys/proc.h>
     #include <sys/module.h>
     #include <sys/sysent.h>

     SYSCALL_MODULE(name, int *offset, struct sysent *new_sysent,
	 modeventhand_t evh, void *arg);

DESCRIPTION
     The SYSCALL_MODULE() macro declares a new syscall.	 SYSCALL_MODULE()
     expands into a kernel module declaration named as name.

     The rest of the arguments expected by this macro are:

     offset	 A pointer to an int which saves the offset in struct sysent
		 where the syscall is allocated.

     new_sysent	 is a pointer to a structure that specifies the function
		 implementing the syscall and the number of arguments this
		 function needs (see <sys/sysent.h>).

     evh	 A pointer to the kernel module event handler function with
		 the argument arg.  Please refer to module(9) for more infor‐
		 mation.

     arg	 The argument passed to the callback functions of the evh
		 event handler when it is called.

EXAMPLES
     A minimal example for a syscall module can be found in
     /usr/share/examples/kld/syscall/module/syscall.c.

SEE ALSO
     module(9)

     /usr/share/examples/kld/syscall/module/syscall.c

AUTHORS
     This manual page was written by Alexander Langer ⟨alex@FreeBSD.org⟩.

BSD				January 7, 2005				   BSD
[top]

List of man pages available for FreeBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net