SET man page on NetBSD

Man page or keyword search:  
man Server   9087 pages
apropos Keyword Search (all sections)
Output format
NetBSD logo
[printable version]

SET(9)			 BSD Kernel Developer's Manual			SET(9)

NAME
     SET — primitive bit macros

SYNOPSIS
     #include <sys/types.h>

     void
     SET(val, x);

     void
     ISSET(val, x);

     void
     CLR(val, x);

DESCRIPTION
     These macros define three standard bit-operations:

	   1.	SET() sets the bit x in val;

	   2.	CLR() clears the bit x in val; and

	   3.	ISSET() returns 1 if the bit x is set in val.

SEE ALSO
     bits(3)

BUGS
     The rationale is to provide clarity in the source code, but arguably
     these operations are clear enough without the use of the macros.

BSD				April 13, 2010				   BSD
[top]
                             _         _         _ 
                            | |       | |       | |     
                            | |       | |       | |     
                         __ | | __ __ | | __ __ | | __  
                         \ \| |/ / \ \| |/ / \ \| |/ /  
                          \ \ / /   \ \ / /   \ \ / /   
                           \   /     \   /     \   /    
                            \_/       \_/       \_/ 
More information is available in HTML format for server NetBSD

List of man pages available for NetBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net