KASSERT man page on PC-BSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
PC-BSD logo
[printable version]

KASSERT(9)		 BSD Kernel Developer's Manual		    KASSERT(9)

NAME
     KASSERT — kernel expression verification macro

SYNOPSIS
     options INVARIANTS

     #include <sys/param.h>
     #include <sys/systm.h>

     KASSERT(expression, msg);

DESCRIPTION
     In a kernel compiled with options INVARIANTS, the KASSERT() macro tests
     the given expression and if it is false, calls the panic(9) function,
     terminating the running system.

     In a kernel that does not have options INVARIANTS, the KASSERT() macro is
     defined to be a no-op.  The second argument is a printf(9) format string
     and its arguments, enclosed in parentheses.

EXAMPLES
     The kernel function vput() must not be called with a NULL pointer.

	   void
	   vput(vp)
		   struct vnode *vp;
	   {
		   struct proc *p = curproc;
		   KASSERT(vp != NULL, ("vput: null vp"));
		   ...
	   }

SEE ALSO
     config(8), panic(9)

AUTHORS
     This manual page was written by Jonathan M. Bresler ⟨jmb@FreeBSD.org⟩.

BSD			       January 14, 2000				   BSD
[top]

List of man pages available for PC-BSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net