ISO man page on 4.4BSD

Man page or keyword search:  
man Server   1065 pages
apropos Keyword Search (all sections)
Output format
4.4BSD logo
[printable version]

ISO(4)			 BSD Kernel Interfaces Manual			ISO(4)

NAME
     iso — ISO protocol family

SYNOPSIS
     #include <sys/types.h>
     #include <netiso/iso.h>

DESCRIPTION
     The ISO protocol family is a collection of protocols that uses the ISO
     address format.  The ISO family provides protocol support for the
     SOCK_SEQPACKET abstraction through the TP protocol (ISO 8073), for the
     SOCK_DGRAM abstraction through the connectionless transport protocol (ISO
     8602), and for the SOCK_RAW abstraction by providing direct access (for
     debugging) to the CLNP (ISO 8473) network layer protocol.

ADDRESSING
     ISO addresses are based upon ISO 8348/AD2, Addendum to the Network
     Service Definition Covering Network Layer Addressing.

     Sockets bound to the OSI protocol family use the following address struc‐
     ture:

     struct iso_addr {
	  u_char    isoa_len;  /* length, not including this byte */
	  char	    isoa_genaddr[20];  /* general opaque address */
     };

     struct sockaddr_iso {
	  u_char    siso_len;	   /* size of this sockaddr */
	  u_char    siso_family;   /* addressing domain, AF_ISO */
	  u_char    siso_plen;	   /* presentation selector length */
	  u_char    siso_slen;	   /* session selector length */
	  u_char    siso_tlen;	   /* transport selector length */
	  struct    iso_addr siso_addr; /* network address */
	  u_char    siso_pad[6];    /* space for gosip v2 SELs */
     };
     #define siso_nlen siso_addr.isoa_len
     #define siso_data siso_addr.isoa_genaddr

     The fields of this structure are:

     siso_len:
	     Length of the entire address structure, in bytes, which may grow
	     to be longer than the 32 bytes shown above.

     siso_family:
	     Identifies the domain: AF_ISO.

     siso_tlen:
	     Length of the transport selector.

     siso_slen:
	     Length of the session selector.  This is not currently supported
	     by the kernel and is provided as a convenience for user level
	     programs.

     siso_plen:
	     Length of the presentation selector.  This is not currently sup‐
	     ported by the kernel and is provided as a convenience for user
	     level programs.

     siso_addr:
	     The network part of the address, described below.

TRANSPORT ADDRESSING
     An ISO transport address is similar to an Internet address in that it
     contains a network-address portion and a portion that the transport layer
     uses to multiplex its services among clients.  In the Internet domain,
     this portion of the address is called a port.  In the ISO domain, this is
     called a transport selector (also known at one time as a transport
     suffix).  While ports are always 16 bits, transport selectors may be of
     (almost) arbitrary size.

     Since the C language does not provide convenient variable length struc‐
     tures, we have separated the selector lengths from the data themselves.
     The network address and various selectors are stored contiguously, with
     the network address first, then the transport selector, and so on.	 Thus,
     if you had a nework address of less then 20 bytes, the transport selector
     would encroach on space normally reserved for the network address.

NETWORK ADDRESSING.
     ISO network addresses are limited to 20 bytes in length.  ISO network
     addresses can take any format.

PROTOCOLS
     The ARGO 1.0 implementation of the ISO protocol family comprises the Con‐
     nectionless-Mode Network Protocol (CLNP), and the Transport Protocol
     (TP), classes 4 and 0, and X.25.  TP is used to support the
     SOCK_SEQPACKET abstraction.  A raw interface to CLNP is available by cre‐
     ating an ISO socket of type SOCK_RAW.  This is used for CLNP debugging
     only.

SEE ALSO
     tp(4), clnp(4), cltp(4)

BSD			       November 30, 1993			   BSD
[top]

List of man pages available for 4.4BSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net