GROUP(5) BSD File Formats Manual GROUP(5)NAME
group — format of the group permissions file
The file ⟨/etc/group⟩ consists of newline separated ASCII records, one
per group, containing four colon ‘:’ separated fields. These fields are
group Name of the group.
passwd Group's encrypted password.
gid The group's decimal ID.
member Group members.
The group field is the group name used for granting file access to users
who are members of the group. The gid field is the number associated
with the group name. They should both be unique across the system (and
often across a group of systems) since they control file access. The
passwd field is an optional encrypted password. This field is rarely
used and an asterisk is normally placed in it rather than leaving it
blank. The member field contains the names of users granted the privi‐
leges of group. The member names are separated by commas without spaces
or newlines. A user is automatically in a group if that group was speci‐
fied in their /etc/passwd entry and does not need to be added to that
group in the /etc/group file.
SEE ALSOsetgroups(2), initgroups(3), crypt(3), passwd(1), passwd(5)BUGS
The passwd(1) command does not change the group passwords.
A group file format appeared in Version 6 AT&T UNIX.
BSD April 19, 1994 BSD