DEVICE_PROBE man page on DragonFly

Man page or keyword search:  
man Server   44335 pages
apropos Keyword Search (all sections)
Output format
DragonFly logo
[printable version]

DEVICE_PROBE(9)		 BSD Kernel Developer's Manual	       DEVICE_PROBE(9)

NAME
     DEVICE_PROBE — probe for device existence

SYNOPSIS
     #include <sys/param.h>
     #include <sys/bus.h>

     int
     DEVICE_PROBE(device_t dev);

DESCRIPTION
     This device method should probe to see if the device is present.  It
     should return 0 if the device exists, ENXIO if it cannot be found.	 If
     some other error happens during the probe (such as a memory allocation
     failure), an appropriate error code should be returned.  For cases where
     more than one driver matches a device, a priority value can be returned.
     In this case, success codes are values less than or equal to zero with
     the highest value representing the best match.  Failure codes are repre‐
     sented by positive values and the regular unix error codes should be used
     for the purpose.

     If a driver returns a success code which is less than zero, it must not
     assume that it will be the same driver which is attached to the device.
     In particular, it must not assume that any values stored in the softc
     structure will be available for its attach method and any resources allo‐
     cated during probe must be released and re-allocated if the attach method
     is called.	 If a success code of zero is returned, the driver can assume
     that it will be the one attached.

     Devices which implement busses should use this method to probe for the
     existence of devices attached to the bus and add them as children.	 If
     this is combined with the use of bus_generic_attach(9) the child devices
     will be automatically probed and attached.

RETURN VALUES
     A value equal to or less than zero indicates success, greater than zero
     indicates an error (errno).  For values equal to or less than zero: zero
     indicates highest priority, no further probing is done; for a value less
     than zero, the lower the value the lower the priority, e.g. -100 indi‐
     cates a lower priority than -50.

SEE ALSO
     device(9), DEVICE_ATTACH(9)

AUTHORS
     This man page was written by Doug Rabson.

BSD				 June 16, 1998				   BSD
[top]

List of man pages available for DragonFly

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net