DEVICE_ATTACH man page on GhostBSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
GhostBSD logo
[printable version]

DEVICE_ATTACH(9)	 BSD Kernel Developer's Manual	      DEVICE_ATTACH(9)

NAME
     DEVICE_ATTACH — attach a device

SYNOPSIS
     #include <sys/param.h>
     #include <sys/bus.h>

     int
     DEVICE_ATTACH(device_t dev);

DESCRIPTION
     Attach a device to the system after the DEVICE_PROBE() method has been
     called and has indicated that the device exists.  The DEVICE_ATTACH()
     method should initialize the hardware and allocate other system resources
     (such as devfs(5) entries).

     Devices which implement busses should use this method to probe for the
     existence of devices attached to the bus and add them as children.	 If
     this is combined with the use of bus_generic_attach(9) the child devices
     will be automatically probed and attached.

RETURN VALUES
     Zero is returned on success, otherwise an appropriate error is returned.

SEE ALSO
     devfs(5), device(9), DEVICE_DETACH(9), DEVICE_IDENTIFY(9),
     DEVICE_PROBE(9), DEVICE_SHUTDOWN(9)

AUTHORS
     This manual page was written by Doug Rabson ⟨dfr@FreeBSD.org⟩.

BSD				January 6, 2005				   BSD
[top]

List of man pages available for GhostBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net