BUF_RECURSED man page on GhostBSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
GhostBSD logo
[printable version]

BUF_RECURSED(9)		 BSD Kernel Developer's Manual	       BUF_RECURSED(9)

NAME
     BUF_RECURSED — checks if the lock linked to the buffer is recursed

SYNOPSIS
     #include <sys/param.h>
     #include <sys/systm.h>
     #include <sys/uio.h>
     #include <sys/bio.h>
     #include <sys/buf.h>

     int
     BUF_RECURSED(struct buf *bp);

DESCRIPTION
     The BUF_RECURSED() function checks if the lock linked to the given buffer
     is recursed and returns 1 if the condition is true, 0 otherwise.

     Its argument is:

     bp	 The buffer linked to the lock.	 See lockmgr_recursed(9) for details.

SEE ALSO
     buf(9), BUF_LOCK(9), BUF_UNLOCK(9), lockmgr(9)

AUTHORS
     This manual page was written by Attilio Rao ⟨attilio@FreeBSD.org⟩.

BSD			       January 22, 2008				   BSD
[top]

List of man pages available for GhostBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net