BUF_LOCKFREE man page on GhostBSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
GhostBSD logo
[printable version]

BUF_LOCKFREE(9)		 BSD Kernel Developer's Manual	       BUF_LOCKFREE(9)

NAME
     BUF_LOCKFREE — destroys a buffer's lock

SYNOPSIS
     #include <sys/param.h>
     #include <sys/systm.h>
     #include <sys/uio.h>
     #include <sys/bio.h>
     #include <sys/buf.h>

     void
     BUF_LOCKFREE(struct buf *bp);

DESCRIPTION
     The BUF_LOCKFREE() macro destroys the buffer lock.	 The lock must not be
     held when this macro is called or a panic will result.

     Its argument is:

     bp	 The buffer whose lock is to be destroyed.

SEE ALSO
     buf(9), BUF_LOCK(9), BUF_TIMELOCK(9), BUF_UNLOCK(9), lockdestroy(9)

AUTHORS
     This manual page was written by Chad David ⟨davidc@acns.ab.ca⟩.

BSD				 July 9, 2001				   BSD
[top]

List of man pages available for GhostBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net